MPD Client Volume Control does not work with HiFiBerry Digi+ Pro


Volumio Information

Volumio Version: 2.779
Hardware: Raspberry Pi 3 B+
DAC: HiFiBerry Digi+ Pro

Debug Log

Steps to Reproduce

At “Playback options” -> Volume options,
Set “Mixer Type” to “Software”
Turn “MPD Clients Volume Control” On
Check /etc/mpd.conf, mixer_type is “hardware” (not “software”)
Try to change volume with an MPD Client. Volume cannot change with “No mixer” error
ubuntu:~$ telnet 6600
Connected to
Escape character is ‘^]’.
OK MPD 0.20.0
volume: -1
repeat: 0
random: 0
single: 0
consume: 0
playlist: 1
playlistlength: 0
mixrampdb: 0.000000
state: stop
volume 50
ACK [52@0] {volume} No mixer

Additional Information

Why do you set mixer to software?
Do you save the settings before you check mpd.conf?

Because I wanted to control volume from my MPD Client.
The only two choices of mixer for Digi+ Pro were None and Software.
(I think it is because Hardware mixer does not make much sense to Digi+ as it is not a DAC).
Only Software allows MPD Clients to control volume.

Yes, I saved settings before checking mpd.conf.

Original autido_output section of mpd.conf. (Mixer Type was “None”)
audio_output {
type “alsa”
name “alsa”
device “hw:1,0”
dop “no”

After setting Mixer Type” to “Software” and “MPD Clients Volume Control” to On.
audio_output {
type “alsa”
name “alsa”
device “softvolume”
dop “no”
mixer_device “SoftMaster”
mixer_control “SoftMaster”
mixer_type “hardware”