Mounting Synology LAN->OK WLAN->Not working

the problem refers to the mounting of a networkdrive in NFS mode on the synology DSM. In fact it works well if I connect a LAN directly to the Raspberry. I can search and play music.

Whenever I remove the LAN cable and try to mount the networkdrive via W-LAN, it will not mount. I tried quite a lot but have no further idea on a solution. Help would be very much appreciated.

The setup is as follows:
Fritzbox 7390
Synology DS215j
Synology is connected permanent via LAN to the Fritzbox.
Raspberry 3 + Hifiberry + touchscreen

On the raspberry I have installed the latest version from Volumio. In Synology NFS is activated and the folder on the Synology is correctly adjusted for NFS communication. Access is granted for the relevant IP Address for LAN and WLAN separately with exactly the same attributes.

When connected via LAN, the Folder on the Server shows that it is mounted. When removing the cable the raspberry is connected via WLAN. After reboot, the Folder on the Server shows that it is no longer mounted.
When I try to mount a new testserver, after appr. 2 minutes a “timed out” warning apperas in volumio’s upper right corner.

Internet radio works fine on W-Lan. The connection is indicated with 65 MB/s, which should be sufficient.

I have no clue where to start searching to get access to the synology folder via WLAN. It would be wonderful if somebody could look into the issue and provide me with an idea or solution.

Thanks in advance.

I know you say that you have checked IP address permissions (for NFS), but I would double check … it sounds like wired and wireless may have different IP addresses & consequently each will need to have access rights for NFS.

P.S. You can usually set a range of IP addresses with NFS access rights.

Thank you for your suggestion. Unfortunately it does not bring me further Actually I struggle now since one week to get it mounted by WLAN before I raised the matter in this forum. I have also tested everything I could find in the various blogs dealing with mounting problems.

I also defined an IP-range for the folder, which does not improve the issue. Currently I defined the IPs individually and a range. I am very sure that these IPs I am using are correct. I also defined the IPs for LAN and WLAN to be bound to the device in the router as a fixed IP and checked furthermore the correctness by typing the IP in the browser.

Have you tried using the same IP address for wireless & wired (through the router interface).

Your question is not quite clear to me. The Synology is connected only via LAN to the router and therfore can be accessed only via one dedicated IP address.
The matter refers to the Raspberry with Volumio. If connecetd via Lan to the router, it works fine. If I try the same via WLAN, it wil not mount.

It appears to me as if the WLAN access has different rights assigned causing such trouble. Unfortunately I have no clue, how to check this further, to identify the blocking element in the system.