mounting iTunes folder on Mac in Volumio


I had Volumio working in no time on my Raspberry Pi 2 + Hifiberry Dac+. My supplier, SOSSolutions sells completely installed configurations. So it literally worked out of the box.
However, mounting my iTunes folder (residing on an external HD connected to my iMac) gave me serious trouble. Every attempt to mount it as NAS in Volumio led to a hangup and I had to reboot the PI. I tried every single configuration tip I could find, but no result.
Finally I read about the Linux mount command, enabling you to mount an SMB/cifs volume directly from the command line (requires connecting via SSH with the Rasp Pi).
Using this command from the command line of my Raspberry Pi / Volume server I mounted the shared folder iTunes in the Volumio server. Then I added the same folder as NAS in Volumio and this time: all went well. After updating the library my iTunes music is now visible and playable in Volumio. Since this is the original iTunes folder I don’t need to move my music around. I suppose I have to update the Volumio library when I add music to my iTunes library.
I still don’t know why it didn’t work via the “normal” Volumio menu. But hey, it works now!

These are the steps I followed:

  • sharing the iTunes folder via the Macs system preferences (checking the Windows SMB box in advanced options). When there write down the IP address of your iMac.
  • create a folder on the RaspPi with the following command: mkdir /mnt/ [e.g.: mkdir /mnt/macmusic
  • issue the following command on the command line of the RaspPi:
    sudo mount -t cifs user=% /// /mnt/
    sudo mount -t cifs user=John%secretpsw // /mnt/Itunes

with a folder name you want to give to the music-folder on the RaspPi (I used Itunes)
with the loginname for your iMac (I used the long name)
with the password for your iMac
with the IP-address of your iMac
with the name of the shared folder on your Mac with your iTunes music

I then added a NAS volume in Volumio with the same (remote directory), , and as in the mount command. This worked fine.

I also had a bunch of problems when I initially tried to mount my iTunes folder, stored on an external hard drive attached to my iMac. Ultimately I got it to work as an SMB mount with the Volumio GUI by clicking on Advanced Options and putting this magic string into the Mount flags: