Mounting a Shared Drive

I have been using Volumio with my music stored on a USB drive attached to my Raspberry PI.

It has worked well so far, however I think my USB drive is getting old. Before it dies I would like to switch to a shared drive on a PC in another part of my house.

I can connect to Volumio from every Computer on my home network via the web browser.

My problem is that I cannot seem to “mount” a folder from my network. My PC’s all run windows 10.

Any help would be appreciated.

There are many good explanations about connecting to Windows shares from Linux devices. Make sure you have read some of these. You then need to describe how this fails (or perhaps not :wink:) with Volumio… the more detail you can give here , the more likely that you will receive help. From the Volumio side of the process, you might look to look at the following FAQ

I will ask my question this way . Is there an easy way for my Raspberry Pi Volumio to play music that I have stored in a shared folder located in one of my windows PC’s? I can access this folder from any PC in my house yet my Raspberry Pi Volumio cannot (at least I can’t figure out how to do it).

Is this even possible? Has anyone here done it?


Yes, it can and has been done. Please supply the details of what you have tried, and what errors/problems you have received. There are no mind-readers here.

Well I did it.

Thank you chsims1 for confirming it can be done.

I wish I could tell you exactly what I did.

I can only suggest using angry IP scanner to confirm your IP addresses and your permissions.

Did you ever figure out exactly what the problem was?
I am new to Volumio and having the same issue. Volumio see’s the laptop but I cant mount the folder for the life me.

I gave up on volumio and raspberry pi. It just wasn’t worth it. You’ll fix this issue and it will work for a day and then it won’t anymore. I’ve got better things to do with my time than constantly tinker with this thing so I can listen to music.

I can’t figure out how to see my shared folder in Win10 either.

network works fine. really no documentation on how to make this work, only for NAS.

when I shutdown Volumio it just spins and spins and spins, does not shutdown.

Sorry to hear that. I needed to replace the streamer in my “second” system over the Holidays and sourced a 4Gb Pi 4B kit locally (that’s South Africa, so can’t take availability for granted!). In 15 minutes had everything assembled and fired it up with the latest Volumio Pi version flashed on a micro SD card. Took a few tries to get everything configured properly but in no time was streaming music from my >1Tb music library on a Synology NAS drive. It’s been trouble-free motoring in the 2-3 weeks since then - glitch-free streaming of standard to high def (24bit - 192Hz) music files.
Not sure what model Pi or how recent the Volumio OS are that you were using - but maybe worth giving it another try.
BTW: this is/was my first experience of the Raspberry stuff - so, could be beginners luck (but we don’tthat’s realistic, right?) …I’m a very ungeeky music lover :wink: