Mounting a Samba share

When I try to mount a samba share as in

root@volumio:/mnt/NAS# sudo mount -t cifs -o user=myuser,password=maypassword,rw,file_mode=0777,dir_mode=0777 //192.168.0.6/Music/Flac /mnt/NAS/TonidoPlug2 mount: block device //192.168.0.6/Music/Flac is write-protected, mounting read-only mount: cannot mount block device //192.168.0.6/Music/Flac read-only

…it fails miserably!

dmesg shos the following:

[83905.764040] CIFS VFS: Send error in SessSetup = -13 [83905.772342] CIFS VFS: cifs_mount failed w/return code = -13

Any idea?
Thanks

…exactly the same problem with Volumio 1.4.

I can access the same Samba share with username/password from my Mac with no issues.

Does anybody have any suggestion?

Thanks

Tried again…

root@volumio:~# mount -t cifs //192.168.0.6/Music -o username=root /mnt/TonidoPlug2 mount: block device //192.168.0.6/Music is write-protected, mounting read-only mount: cannot mount block device //192.168.0.6/Music read-only
“Music” is the name of the samba share defined in smb.conf of my TonidoPlug2 device (which I’m trying to mount) and the mount point “/mnt/TonidoPlug2” already exists.

I also tried to install cifs-utils, but again, no joy!

root@volumio:~# apt-get install cifs-utils Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package cifs-utils
Thanks
franz

I got this working in this way:

  1. install cifs-utils

apt-get update apt-get upgrade apt-get instal cifs-utils
Just wait for the appropriate amount of time for the upgrade to complete.

  1. Mount the samba share.
    In my case I had to bypass security to overcome a “permission denied” error I was getting
    Returning a permission error:

root@volumio:/mnt# mount -t cifs //192.168.0.6/Music -o username=root /mnt/TonidoPlug2 Password: mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Working:

mount -t cifs //192.168.0.6/Music -o sec=none /mnt/TonidoPlug2

this seems still an issue…?
I can mount a share from other machine but not from the volumio.
I installed the fresh image 1.55 from 7 feb 2015 …

UPDATE

sudo mount -t cifs -o sec=ntlm,username=hugo,password=****** //192.168.178.57/archief /home/pi/archief

works from commandline ssh

and option in advance mount options “sec=ntlm” no quotes works in GUI… finally…

Thanks! Works like a charm.