Mount WD mybooklive

I am having a lot of trouble mounting a WD mybooklive, I have tried both device name and IP address.

I am getting mount error message 22 trying to mount using CIFS

I also have a WD EX4, this mounted no trouble, problem is i use the mybooklive for music storage.

I have googled and can see that lots have had problems with mybooklive but i haven’t been able to find a solution. Does anyone have a link to a guide or perhaps could share settings of this working, and any user configurations required to make it work ( i did try adding a user for volumio)

Thanks in advance for any pointers that can be given.

Hi there, I’ve installed Volumio for the first time literally 30 minutes ago - and got My book Live shares working right away.

I typed the address as an IP, not a logical name:
(no slashes, no quotes, nothing - and, of course, use your book’s IP!)

Then I typed the share name with the path where I keep my music:
(not sure if you need the slash, but I have it and it works, so… :slight_smile: )

The, clicking “Show Advanced Options”, you have text boxes for the username and password for that share. I have no idea if it works without authentication, didn’t need to try it.

That’s it! Of course, both drives need to be in the same LAN, and visible to each other. I’m sure you can turn ssh on in volumio and try pinging the wdbooklive to see if that’s the case. Hope you get it to work!

Thanks Stocker, glad yours works out of the box, that gives me some comfort that it will work eventually.

I am still struggling though, no matter what i do i cannot get volumio to log into my NAS.

I don’t use a password for it, i have connected to volumio by SSH to try and mount this way, however it asks for a password which i don’t have, i set one which it wouldn’t accept and i reset my NAS to its default password but again volumio still wont accept

volumio@test:~$ sudo mount.cifs // /mnt/NAS
Password for root@// *****
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I am really at a loss now, so any ideas welcome

sudo mount -t cifs // /mnt/NAS

…but why don’t you just mount it via the Volumio UI?

it wont let me mount via the UI, i just get a mount error 22

Have you tried to set “vers=1.0,” in option ?

balbuze that was exactly what I was missing, mounted now, thank you

Can you tell me what that setting changes for future reference?

Yes, it’s the SMB protocol to use. Note that smb 1 is considered by some as a security risk; if you have time, a better solution would be seeing if you can set the protocol on your NAS to 2 or 3 by default.

Volumio was working for me well until a couple of nights ago, when it lost contact with the networked MyBookLive, which contains all my media files. Nothing I could do would get it to recognise the drive. All the errors mentioned above popped up as I struggled with different combinations of username and password, or without any.

I then substituted Rune Audio, and it recognised the network drive instantly – so why wouldn’t Volumio? I even downloaded a fresh instance of Volumio and restarted the Pi – same errors. Right now, Volumio DOES NOT WORK with my MyBookLive. Too bad! It was not too bad an interface.

Could this issue be finally corrected?

Seems to me a lot of time keeping is needed to get simple things working, I’m not a tinkerer but do indeed want to purchase a nas, I must admit I’m being put off by reading all the problems people are having
Most discouraging.

Hi Guys,

I just set up Volumio on a Raspberry 4B. Everything works smoothly, but the NAS mounting. I happen to have a WD MyBookLiveDUO. Unfortunately, I tried all of your recommendations above, but nothing works.

On NAS side, I activated the dlna server and released the share I like to access for media streaming.

In Volimio UI the NAS only is detected, after setting up a initial version manually. Then the scan function can detect the device. However connection always leads to error 22 or 13.

Some times when I go at it via SSH I can get the Pi to register the username@ // for connection and password query instead of root@ //, be after entering the pw error 13 “permission denied” occures.
Btw. I have to use options vers=1.0, sec=nltm. This however does not work every time I try it.

Do you have any other I deas Incan fix the issue, except buying a new Nas?

Best regards

Hi Xenorollmops, welcome to Volumio. :slight_smile:

Firstly, it’s better to not resurrect 3 year old threads, things change, so starting your own thread would have been better.

So all of your media should already be available to Volumio without needing to add a share in Volumio. You do need to enable DLNA/UPnP in the ‘sources’ section of the settings.

Yes, the automatic detection does not work in all cases, it depends on your setup. It has never worked for me :frowning:

Does the attempted scan stop immediately, and you are shown a cross near your network drive details, or does the scan actually start and you can see numbers of tracks appearing at the top of the screen?

You should always be able to access the Pi by ssh (once it has been enabled) by going to, but login as root is not allowed.

Have you correctly enable cifs/nfs file-sharing on your NAS? Have you double-checked that you are using the correct ‘path’ to the share?

No idea of the age of your NAS, but on newer models there is (at least in my Synology) an option to set the cifs version to what you want.

Hi chsims1, thanks for the quick response.

Sorry for that, rookie mistake.

The scan/mounting process always stops immediately, and shows a cross like the lower one. Hence there are no tracks found.
The path I use is correct for sure. I tried IP adess, and “MYBOOkLIVEDUO”. I can not make the syntax of the “path” in the UI, matche the one you describe under “The Sutherlands”. The API always changes it to the on under test.

There is no option to turn the protocols on or off. They should be supported by default. There are also no option to select a version of any sort. The Device is quite old.

Access via SSH to the PI is no issue. I was talking about the attempts to mount the NAS via command line. Perhaps that was slidely poorly described.

Btw. to clarify, pi and Nas have the permission to open ports by themselves in my router.

Does that make any sense to you?

Ps: I would prefer not to use dlna, because it is not pw protected

Would you share some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

Fixed it!

I set up a new user on my NAS to create a Log for you and all of a suddon, the process works over the UI using only “vers=1.0”. Turns out, my Admin account has nasty special characters in it, volumio can not process. I was not aware of that…

Thanks for your patience and support.

I will be back for questions about the GPIO interface for sure, but in an other thread then. :grin:

Conclusion: WD MYBOOKLiveDuo can be mounted via WEB UI using the the Option “vers=1.0” and no special cahracters in the pw.