Miuzei 4 inch IPS Touch Screen LCD Display

Nothing shows on the screen after typing ca /dev/input/event* from a ssh terminal.
output from udevadm:
volumio@jukebox:~$ udevadm info -q all -n /dev/input/event*
P: /devices/platform/soc/fe204000.spi/spi_master/spi0/spi0.1/input/input0/event0
N: input/event0
L: 0
S: input/by-path/platform-fe204000.spi-event
E: DEVPATH=/devices/platform/soc/fe204000.spi/spi_master/spi0/spi0.1/input/input0/event0
E: DEVNAME=/dev/input/event0
E: ID_PATH=platform-fe204000.spi
E: ID_PATH_TAG=platform-fe204000_spi
E: DEVLINKS=/dev/input/by-path/platform-fe204000.spi-event

The other thing that I found strange is that I could never get another SD card to work. After installing the Touch Screen plugin and apply the userconfig.txt change, the screen always display “not support”. Volumio is actually running on these SD cards, the Web UI works fine with these cards.

1 Like

You could try if the touchscreen works using evdev instead of libinput: Install xserver-xorg-input-evdev running

sudo apt-get -y install xserver-xorg-input-evdev

After that execute

sudo cp /usr/share/X11/xorg.conf.d/10-evdev.conf /usr/share/X11/xorg.conf.d/45-evdev.conf

and reboot.

I have no imagination how and where that message would appear. Could you post a picture?

This is the display on the screen.

Does this appear when you enable the Touch Display plugin?

How does the screen look when the plugin is disabled?

What HDMI output of the Pi is the display connected to?

I will try that. I saw this message when I booted up the unit with the touch screen problem. Hope this shed some light on why the touch does not work.

Did you change the Volumio password?

Yes. It won’t let me change back to volumio.

Don’t do that! For more see Change Volumio account password?

I suggest you start from scratch…

I changed the password back to volumio and the touch is working now. However, I am still puzzled why I could not get another SD cards to work using the same procedure. Strange! Anyway, you have been very helpful…Really appreciate you spending the time helping me.

The problem could have been solved a lot faster, if I had realized that the display did not even show Volumio’s UI. :joy: But unfortunately based on the sentences “The problem I have is with the touch. When I touch the screen with the pen, the display does not respond to the touch.” I understood your post above to mean that only the touch function does not work, but that the display does… Anyhow, I’m glad that it works now. :+1:

Can’t comment on that issue, but I have seen that other users seem to have problems flashing the Volumio image properly using certain imagers (see Updating To Volumio 3 Has Caused no end of trouble).

The display does work even with that error message about the password with the Touch Screen plugin.

I guess that already the installation of the Touch Display plugin was affected by the different password setting in a bad way. I suggest to at least uninstall the plugin and install it again. Maybe it’s the better (and faster) to start with a fresh Volumio.

I have tried many times with a fresh volumio. None of the attempts brought up the display. On the working machine, I can see the signon screen pops up during the boot. On the failed machine, the screen will flash orange and then change to blue screen. I must have tried more than10 times to create a working machine but they all failed. I am keeping the working one.


Is that a Miuzei 4", too?

BTW: Is the screen connected to HDMI0 of your Pi4?

I have only one RPI 4 machine with the 4” Miuzei screen. All the testing has been done on that machine. I have used different brands of micro SD card for the testing. The screen is connected to HDMI0 ( port next to the USB-C power connector)

You could try the following:

  1. Download “99-fbturbo.conf”:

sudo wget https://raw.githubusercontent.com/goodtft/LCD-show/master/usr/99-fbturbo.conf-HDMI -P /usr/share/X11/xorg.conf.d

sudo mv /usr/share/X11/xorg.conf.d/99-fbturbo.conf-HDMI /usr/share/X11/xorg.conf.d/99-fbturbo.conf

  1. Change the driver setting in “99-fbturbo.conf” from “fbturbo” to “fbdev”:

sudo sed 's/"fbturbo"/"fbdev"/' -i /usr/share/X11/xorg.conf.d/99-fbturbo.conf

  1. Reboot.

I also tried these steps but nothing happened.

I also have issues with touch input - but it’s not that touch does not work, it’s that when lcd display output is rotated, the touch input still registers as if it’s of a 0 degree rotation. So that messes up the input.

Not sure if that’s the real issue that others are having too.

What does that mean? In post #9 you wrote

If you should not be referring to any (visual) display problems but to the touch issues

you are mentioning, have a little patience: