Missing Kernel Headers

Dear all,

I am completely out of my league here (in the developers corner) but I will try to describe what the issue is I found and hopefully you can tell me if this is something that can be solved or even is provided for in Volumio 3…

I’ve bought an Rpi Hat with a Cronos reclocker from Twisted Pear Audio which requires a piece of software addition: Github
We (I got some help) were unable to install this successfully onto the Pi with Volumio.

root@volumio:/home/volumio/tpa-hermes-rpi-dev# git pull
Already up-to-date.
root@volumio:/home/volumio/tpa-hermes-rpi-dev# make clean
make -C /lib/modules/uname -r/build M=$PWD clean
make[1]: *** /lib/modules/4.19.118-v7+/build: No such file or directory. Stop.
Makefile:27: recipe for target ‘clean’ failed
make: *** [clean] Error 2

On the DIY audio forum they suggested to try the installation with a Raspberry Pi OS, or DietPi since some kernel headers seem to mis:
"Your error message suggests that your kernel headers may not be present:
apt-get install raspberrypi-kernel-headers gcc make device-tree-compiler git"

We’ve tried it with a clean PI Debian OS and the installation succeeded.
It seems that Volumio is dressed down as such that it is missing the essential kernel headers for it to succeed?

I this something that could be supported?

Thank you in advance,


Hi Jordo

Given that your previous post from May has not been answered fully (TPA Cronus, I suspect you my not get any success this time around.

Have you tried DietPi? This is a cut down version of the RPi Debian OS, but has a lot of ‘audio’ options.

Have you tried the volumio kernelsource command?

Kernel headers are not included in the standard image, since it will take lot of space and only a small percentage of users will ever need them.
However, as previously suggested, they can be easily dowloaded by launching the command

volumio kernelsource

1 Like

Hi Yatsushiro,

Thank you for your attention.
Much appreciated!


No we haven’t. Wasn’t aware but if you search for missing kenel headers you find more posts about the subject.

We are going to try this!



Hi all,

We’ve managed to install the kernel headers but we have stumbled upon the following errors.

Anyone any suggestions?