Minix Z64 RTL8723BS and eMMC not detected

Volumio Information

Volumio Version:2.853 PC (X86/X64)
Hardware: Minix Z64 with Intel Z3735F Processor, Realtek RTL8723BS Wifi and eMMC.
DAC: Dragonfly Red

Hi Team,
Yesterday i tried to use Volumio on my Minix Z64. The USB boot was successful. But i could not get the wifi to work and also could see that the eMMC was also not detected.

I had read through some other posts regarding the RTL8723BS and eMMC, i thought that it was supported now. Maybe i have misunderstood.

Could you please let me know if there is any way I will be able to make the volumio detect the eMMC and install it to the eMMC. Also is there any way to make the wifi working.

It would really help a lot if volumio could boot from my eMMC and work using the wifi.

Please advise.


Hi Team,

Any advices or suggestions. I would really appreciate if it was possible to get volumio on my minix.

In the current version these devices are and will not be supported due to an old kernel and corresponding firmware.
My suggestion is to use the x86 buster pre-version as discussed in Volumio Development/ Development talks, that version is fully functional and should cover more newer hardware configurations, incl. support for a wider range of wifi chips, emmc, nvme etc.
An official beta, followed by a release is expected soon.

Hi gkkpch

Thank you for your advice.

The latest x86 buster image 2.857 did solve the eMMC install issue. So now i have successfully installed to my disk.

But I am not able to get the wifi up and running. I have been trying for some time on different suggestions in the posts. but no success yet. I get an error on hostapd.service stating
“Could not read interface wlan0 flags: No such device”

I can see that the RTL8723BE drivers are present in the rtlwifi path in libraries. Is it possible to fix this issue.

You would have to run a log from the dev page, this may give us more info.
(http://“your ip”/dev)
Post the url it returns.

Something confuses me, in the OP you mention RTL8723BS.
In the previous post you say RTL8723BE
You have to decide which one it is BE or BS?
They are not the same, BS would be an issue.

Please find the attached files. The Log.txt is the output from http://“your ip”/dev. The other file is the output from lsmod.

From my bios i saw that the device was RTL8723BS.

Also when i ran the dmesg | grep -i 8723, i got the below result
[ 0.387236] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)

Thank you

Log.txt (4.4 KB) lsmod.txt (8.3 KB)

sorry, live log does not help (my fault, should have been more clear)
Could you please do the other one instead?
It will show the log since booting the device with a few other things.

Happy Christmas.

I have attached the file from sudo journalctl -b after a fresh reboot.

putty.log.txt (262.9 KB)

On a side note, i have observed that the latest debian buster image does not show any plugins in search screen. I ran the below and got the results successfully.

arch=$(dpkg --print-architecture)
curl -L${arch}/plugins.json

Please let me know if i should report another bug for the plugin issue

Also i think there is an issue with the Airplay service. I cannot see the volumio as airplay device. When i run the systemctl status shairport-sync.service i get the below. But the Sharepoint-Sync under the Sources settings is enabled and green. Please let me know if i should report each as individual bugs

volumio@volumio:~$ systemctl status shairport-sync.service
● shairport-sync.service - Shairport Sync - AirPlay Audio Receiver
Loaded: loaded (/lib/systemd/system/shairport-sync.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2020-12-25 21:14:55 UTC; 1min 0s ago
Process: 9170 ExecStart=/usr/local/bin/shairport-sync --configfile=/tmp/shairport-sync.conf (code=exited, status=203/EXEC)
Main PID: 9170 (code=exited, status=203/EXEC)

Dec 25 21:14:55 volumio systemd[1]: Started Shairport Sync - AirPlay Audio Receiver.
Dec 25 21:14:55 volumio systemd[9170]: shairport-sync.service: Failed to execute command: No such file or directory
Dec 25 21:14:55 volumio systemd[9170]: shairport-sync.service: Failed at step EXEC spawning /usr/local/bin/shairport-sync: No such file or directory
Dec 25 21:14:55 volumio systemd[1]: shairport-sync.service: Main process exited, code=exited, status=203/EXEC
Dec 25 21:14:55 volumio systemd[1]: shairport-sync.service: Failed with result ‘exit-code’.

why can’t you just do a simple readable volumio log instead of your own logs and suggestions.
Please do the log on the dev page and post the url you get.

Sorry. I misunderstood your request. Now i have sent the log. The URL is

I do not see, at any point, an attempt to initialize the RTL8723BS hw interface.
No driver load and no attempt to load 8723bs firmware.
Could you run this for me (ctrl-alt F1 will give you a terminal, with volumio/volumio to input for uid/pwd):

inxi -vFzxxx

With the ctrl-alt F1, i couldn’t figure out how to extract the output. So i managed to run via SSH.

The output is Output.txt (2.1 KB)

Thanks, this shows no onboard rtl8723bs device was detected, meaning there is nothing else I can do to help.
You may have to try a usb dongle to get wifi.

That’s fine. Thank you for the confirmation. Just to know is that also why airplay is not available.

your eth0 connection should work, it is initialized and gets an ip address.
Airplay only works when you have a LAN connection, be it wireless or wired eth0.

My eth0 is up and running. But i don’t see the Volumio as the airplay device in my iphone.

For the wifi issue. I will for now change my setup and use Volumio in a wired setup. Later on i will get a wifi dongle and a usb hub.

If the Airplay starts working, it will be very helpful.

Should it be reported as separate issue because the problems i reported in this thread is solved.

Looks like the RTL8723BS is detected as mmc. I know that this chip is an SDIO and i can see it under id mmc1 (mmc1:0001:1).

I found the below using command “udevadm info /sys/bus/sdio/devices/mmc1:0001*” but i dont know how to make it detect correctly.

P: /devices/platform/INT33BB:00/mmc_host/mmc1/mmc1:0001/mmc1:0001:1
L: 0
E: DEVPATH=/devices/platform/INT33BB:00/mmc_host/mmc1/mmc1:0001/mmc1:0001:1
E: SDIO_ID=024C:B723
E: MODALIAS=sdio:c07v024CdB723

interesting, i’ll have another look at the kernel configuration and make sure everything related to sdio is enabled.
As for airplay, yes please post this in the Volumio Development/ Development talks’ X86 buster thread.
We are pushing buster, so it is important not to forget this issue.