minidlna in volumio 2

I had previously been using my rpi to host files via minidlna, but that package no longer seems to be included in volumio. Will it cause me any problems by adding it with apt-get? I see other threads warning against apt-get upgrade so I wanted to check if apt-get in general was a problem, or just the upgrade.



Apt-get install is absolutely fine! So you can install minidlna…
PS: In the future we’ll have a plugin for it…

It’s working great now, thanks!

Hello, and thanks again Gi and the team for your great work!

I’m using Volumio 2 (2.118) with a RPI 3, Allo Boss + Volt. This is working fine using the WebUI.
I’m trying to stream music from my Android phone (an old Samsung Galaxy S3 mini, converted into a dedicated remote for Volumio, rooted and running Cyanogenmod 10.2 - Android 4.3).

The Android apps I’m trying to use are: AllConnect, AirAudio and AllStream. I also tested BubbleUPnP but less successfully .
@Gi, I also read your post with the official Volumio app, but I don’t think it will be a short term solution (in addition to the fact that it doesn’t find Volumio on my network for now :frowning: ).

I can stream music over Airplay, but with a lot of interruptions and scratches.
I cannot connect to the DLNA server: I understand that I have to install minidlna (now Ready Media ?)
In addition, I don’t really understand who decides which music is sent to the speaker: the Web UI becomes unresponsive when I use Airplay, but I’d like to change the volume for example. Or to change the music and use the Web UI.

I’ll continue to look into the forum, and try to install and configure it (thanks to mini-dlna-t4546.html) , but I see posts that are a few months old now: is there an update about the plugin?

Concerning the Airplay issue: does it come from my phone (too old?)? The network? Volumio? The RPI? Do you see any solution?

PS : I have similar issues with my PC on Windows 10. I tried to use the SWYH (Stream What You Hear 1.4), but that’s only working with the “HTTP live streaming function”. Finally, I tried TuneBlade, which is working over airplay. Both are working, but with some interruptions and scratches in the speaker when I change the music.

DLNA problem solved: I had to configure the wav format on my source.

But it remains the issue about lags and interruption :frowning: Any idea?