m4a support?

Hi Michelangelo,

There is a problem indexing m4a files.
In the past i bought lots of music via iTunes.

Volumio doesn’t see m4a files.

Can you tell me how to add support for m4a files?

Thank you.

Found it.

I disabled this in mpd.conf

decoder {
plugin “ffmpeg”
enabled “no”

Are there any problems to expect in this case?

well this was added as a bugfix for db taking ages to update. If you just remove that your database may take long time to update, but if you just leave it alone it will complete with no problems. Let me know how it goes!


I’ve got about 6000 albums on a Synology nas (DS209+II) connected via SMB/CIFS.
The Synology is wired with cat5 on a Gigabit network. My Raspberry Pi is connected wireless.
My wireless router is a Cisco Linksys E4200-V2.
With rsize and wsize of 32768 and edited mpd.conf (see second post) it only takes about two hours to complete the db update.

Also the onboard LAN is disabled to reduce USB polling (maybe not necessary but it doesn’t hurt anyway)
See http://www2.robpol86.com/lapdock/Atrix-Lapdock-with-a-Raspberry-Pi on how to do this.

My wireless adapter is an Edimax EW-7811Un [Realtek RTL8188CUS]
I disabled the edimax powersave feature:

sudo su echo 'options 8192cu rtw_power_mgnt=0 rtw_enusbss=0' >> /etc/modprobe.d/8192cu.conf
The dac i’m using is the XMOS sabre 9023 combo (your reference dac on http://www.raspyfi.com/building-my-reference-dac)
Sounds very good.

I’ve done some more tweaks, but this isn’t the thread to discuss it.

I just registered to ask about ALAC files. I have a lot of them and I can’t see them in my Library. Thanks!