Loud Plop/Click when starting tracks manually

Volumio Information

Volumio Version: 2.0
Hardware: Primo HiFi
DAC: Primo HiFi

Hi!
I am the recent owner of a Volumio Primo HiFi. I am quite happy with the sound quality and functioning of the device. I had some difficulties to have the tagging system working correctly but I think I got it now.

My setup consists on the Primo connected by analogue RCA (so fully using the great Primo DAC) to my Sony ES Pre-Amp and Ethernet wired to my cable Router. I also have an USB WD Elements Portable connected to the Primo’s USB, where are my files.

I had some issues with slow file transfers from my laptop to the USB drive on the Primo, but then I understood that the Primo do not disable Wi-Fi when the Primo is connected by Wi-Fi and Ethernet. I think it should be automatic but I needed to disable Wi-Fi to have it working primarily by Ethernet. Now it is connecting quite fast.

Previously I was a user of Foobar and then of JRiver connected by USB to a Cambridge Audio 851C CD/DAC. I also record a lot of DAT tapes having the Digital Out of the 851C to a Sony DAT recorder. For this, it is very important that the media player may have an option like ‘on starting a song it can delay a couple of seconds for hardware synchronization’. Foobar and JRiver have this ‘delay’ option that can be selectable and configured. Otherwise, when recording, the DAT will not be able to record the first second or fraction of the song. Of course this just applies when start playing, all the remaining tracks will play gapless.

I am sorry for the long introduction but I thought I should present all clearly.
At this moment I am facing an annoying issue with Volumio that I think it is connected with the immediate start after pressing play on the ‘console’:

  1. For some FLAC files there a loud annoying plop/click noise when starting a track manually, if the track is in a playlist of playing the full album it does not happen. I noticed that it always happens with the same songs and sometimes occasionally/randomly not so loud with others.
    I tried this same songs in Windows Media Player and with JRiver via 851C DAC and this doesn’t happen.
  2. When recording to the DAT connected to the Digital Out of the Primo, as there is no time for hardware synchronization, the very beginning of the songs is not recorded.

I couldn’t find an option for these settings and it is very important to me to use the Primo as my main player/renderer/DAC. Can you please help here?
I believe that solving these could also help other users and give extra points against other players. I really like Volumio and I wanted to stay with it without any reservations but these points are very important for me.

Thank you in advance.

Kind regards,
Carlos

@DED could you look in to this for carlos

Hi dvo and thank you for immediate attention.

Today I tried another option: I connected the 851C DAC to the Primo by USB, so the Primo’s DAC was bypassed, and the RCA out of the 851C/DAC connected to the pre-amplifier. The Primo’s recognized the 851C/DAC without any problems, so I did chose the 851C/DAC as the output on the Primo.

I played the same files on Volumio and the click/plop noises are not present this way, so perhaps is something related with the Primo’s DAC or internal driver?

With the DAC now connected directly to the Digital out of the 851C DAC, also no problems recording with the DAC.

But this way I can’t use the Primo as my only device which was my purpose: have only one device as a streamer and as a DAC.

I hope this contributes to a solution.

Kind regards

Carlos

nice some combinations will work some not that is what i read a lot of the time,
glad you found a way and maybe primo techsupport can help you with it …
it could be a setting …

This way was to test only, I want to have only one device streamer/DAC with DSD. The 851C does not play DSD. The Primo would be a nice solution if these issues can be solved :slight_smile:

Hi again!

Some more tests done.

The files in question were all FLAC 16b-44,1KKz.

Only with the Primo connected by RCA to the pre-amp, if I configure ‘Audio resample’ to ON and try to change ‘Target Sample’ here is what I get:

Native: – same pop/clicks in the beginning of file when selecting manually

44,1KHz – same pop/clicks in the beginning of file when selecting manually

48KHz – same pop/clicks in the beginning of file when selecting manually

88,2KHz and above – no pop/clicks in the beginning of these files when selecting manually.

‘Target Bit Depth’ seems to not affect, whichever the setting is.

So I suspect it is something related with the DAC parameters/software.

However, it is important to have it working with ‘Target Sample’ on OFF and get Bit Perfect playing. By the other hand, selecting it to on really affects the DSD files as they play a lot quieter.

Please let me know if this can be solved?

Thank you

Kind regards

Carlos

Hello!

Any updates about these issues?

I found a thread where I can see one of the problems I am having with my DAT using the Digital Coaxial out connection, it is related lock/unlock from the coaxial out.
It seems that it is an old issue, what is the actual status of it?
(link below)

Thank you
Carlos

Hello!

Is someone reading this? Or there is a better way to get support?

Kind regrds
Carlos

Hi Carlos,
saw this just now.

I suggest to contact our support at techsupport at volumio dot org

That’s the quickest way to get support :wink:

Hi!
Thank you I will do that.

Kind regards,
Carlos

The pop’s are related to the DAC, or better related to DSD-DoP.
Volumio can work around this by adding an option (in audio options) to mute the output for small amount of time, when manual changing a track. But this will not work on every DAC.

If all is well, you won’t experience this behavior when using PCM. PCM can, instead of DSD-DoP, sent a true “0” when a track is changed. While DSD only records level changes between samples. When changing tracks volumio can’t send DoP markers, to get back to “0”, the new song will. But as this “0” is not related to the previous sample it will cause the pop or clicks.

Where do you have the option to use PCM stream? In my case the dac only supports PCM, but i can’t select it anywhere, it’s either DoP or DSD from settings. Would be saviour if we had this option, and it indeed did stop the pops which I’m having proplem with aswell.

taken from the info icon within Volumio.

1 Like

i have missread that before, thanks. Sadly it makes no difference no matter which the option is, pops are still there when using the Next/Prev track, for some reason it wont pop always if i select new song from ie. Spotify, dont know what is the difference internally.(and Yes, im positive that no other device of mine makes these pops on neither of my helix DSP.3 or topping DX3 pro)

Please check when you hear no pop if the format is identical like flac 44.1k/16b between the track changes. As changing format can also introduce pop’s.

Hi!
I think that does not apply to this situation. My post refers to Volumio Primo HiFi, not to any other DAC. I see no such options on my Volumio’s menu.