Lost Tidal connect after update

@mervinio
Like @charliesjc and @bbear1, on my Android phone after deleting the Tidal cache and data, uninstalling and reinstalling the Tidal app it’s now working.
I now have Tidal 2.65.1 on my phone (no idea what I had before)
I think it’s weird that there is a TLS error on Volumio, and uninstalling reinstalling the app on Android makes it work again. Does Volumio talk directly to the app on my phone? Or vice versa? Or is the TLS error unrelated?
Anyway I’m just happy that it’s working again, and I don’t have to debug a TLS issue in my spare time - it’s bad enough having to do this at work every second day. :wink:

A few days ago, cleaning the memory and data in the Tidal application helped. Tidal connect started working properly. Today the problem reappeared, this time I reinstalled the Tidal app and it helped. I wonder for how long?

Seems as if this might not be Tidal related as I read on these forums of TLS handshake errors happening with Volumio and Spotify Connect. Hopefully Tidal Connect continues to work on my Volumio Rpi4 setup

Edit: Spoke to soon, Tidal Connect is broken again for me. I got a couple of days listening this time, so frustrating!

1 Like

After struggling forever to keep Tidal Connect stable, the tip to clear the app cache & data seems to have worked. At least in the sense that for a couple of days the app refused any attempt to connect, despite rebooting Pi, etc., and being used to the randomness I switched to the internal Tidal (which is clunky and I miss the Daily Discovery). After reading the this thread and clearing the app cache & data, I could connect immediately and play flawlessly. If it happens again I’ll try just clearing the cache.

WiFi hygiene: Earlier I separated my 5GHz and 2.4GHz network SSIDs so the Pi only connects over 5Ghz; otherwise the Pi seems to prefer 2.4Ghz which is unstable for me. I would not assume wired is better unless proven in your particular case; it’s very particular to the individual environment and wired is just a simple answer to reduce a number of variables. WiFi is peachy keen set-it-and-forget-it for many, many other things.

While the app-data-clearing doesn’t prove the root cause, it does seem to indicate not a network (WiFi) problem (assuming an otherwise working setup), not a reboot-Pi problem, not a restart Android problem, not a re-install anything problem (tried all those many, many times). Time will tell.

1 Like

Just updated Tidal app on my Android phone to 2.66.0 (the latest version took a while to appear on the Canadian Play store!)
Cleared cache and memory, so wait to see if the problem returns
DefintelyNotThor, thanks for the tip on separating the 2.4g and 5g SSIDs. I have a slew of wireless networks in my home from two separate wireless routers, a selection of 2.4g, 5g and 5g AC. At the moment my Pi4 is connected to the 5g AC and has a strong and stable signal. I will keep an eye on it though

We have contacted Tidal and the issue is in the Tidal app. They have fixed the issue and the fix will be released September the 21st.

In the mean time, as a workaround, please reset the app’s cache when you encounter this issue.

1 Like

Sad that it will take so much time.
Also the work around does not work for me. I have reset the cache a few times but it still fails to connect.

It worked for a day or two when I previously reset the cache but then it stopped again.

Have also noticed when streaming from on the Windows version of the Tidal app there is no option for Tidal Connect. Also no option to reset Tidal cache on Windows app.

I’ve always found the Windows app is terrible when trying to use Tidal Connect. I find I need to leave the app open for a while and then it will eventually show me the option to choose the TC device. But sometimes it also just disappears as soon as you open the menu to do so.

It’s already September 22 and the Tidal fix does not appear and Tidal Connect stops working after 2 days, which requires cleaning the memory and data and re-logging

A month later and Tidal Connect is still broken. This was one of the main reasons I signed up for a Premium account and I will not be renewing it when it expires.

me too

1 Like

Yeah, me too. I know its not exactly volumio’s fault but it’s the main reason for me as well.

The fact that i have to pay for tidal + volumio does make it feel worse. I won’t renew this year as long as this is not fixed.

I’ve had 0 issues using the app on Windows 10. Discovers, connects and plays no problem. The Android app is the issue. Not the fault of Volumio at all, hope Tidal gets their act together soon.