Lost Tidal connect after update

After updating Volumio to v3.324 I’ve lost the option to connect to Volumio in the Tidal app.

Have tried restarting the Volumio device and reinstalling Tidal but the option to choose Tidal Connect as sound output does not appear like it used to. Has anyone else experienced this after updating to v3.324 ?

5 Likes

I’ve lost Tidal Connect too. I can still see as an available output but clicking on it does nothing. I’ve cleared cache etc for Tidal on my phone and restarted everything, no change. Latest version of Tidal is installed. My phone recently updated to Android 13, I’m wondering if that has done something…

I have the same problem (Volumio 3.324). I am testing Volumio Premium and for the first week Tidal Connect worked reliably. It hasn’t been working since yesterday. Clearing the cache in Tidal and factory reset in Volumio did not help. Is this a Tidal or Volumio problem?

I am considering whether it is worth continuing the paid subscription to MyVolumio Premium after the trial period … these problems are annoying. I hope for TeamVolumio’s help.

1 Like

I had the same issue, which started before the upgrade happened (I saw the upgrade was available while I was trying to fix the problem). I’ve just cleared cache and data from the Tidal app on my phone and it seems to have resolved the issue.
Update: It does connect and play successfully now, but it disconnects again after a while.

I just tried clearing Data and Cache for Tidal again and it seems to have solved the problem this time.

I also had to this problem, I struggled for half a day: I changed the wifi network, reinstalled volumio, tried to run on moode … and reinstalling the application Tidal on the phone helped !

Clearing data and memory in the Tidal application also helped me. On each device (tablet, smartphone) separately. Thanks for the good instructions.

1 Like

Fully back to normal for me too now. Must have been something on the Tidal end.

Mine has stopped working since today. I’m now on Android Tidal app v2.65.1. A look in the volumio logs for vtcs shows this error:

Aug 22 12:26:07 volumio vtcs[1397]: [2022-08-22 12:26:07] [error] handle_transport_init received error: TLS handshake failed
Aug 22 12:26:07 volumio vtcs[1397]: [2022-08-22 12:26:07] [info] asio async_shutdown error: asio.ssl:336462231 (shutdown while in init)
1 Like

We are currently investigating this issue, allthough it seems to be on Tidal side.

As a workaround, please uninstall / reinstall the Tidal app or clear the app cache and data. Let us know if it works for you.

1 Like

Clearing cache and uninstalling etc doesn’t work for me. This issue started already from v2.65.0 when I was experimenting with those leaked binaries on the web and now it’s stopped working with v2.65.1 with Volumio.

It works from my Windows machine so the problem for me at least is only with the latest Android version of Tidal. - edit - My Windows machine now connects and does its thing but it loses focus and disconnects leaving Volumio playing and switching to my PC speaker output at the same time. So not really functional.

I am also having the same issue. I uninstalled Tidal app on my android phone and my iPad but it didn’t help.
Tried restarting Volumio, shutting Volumio down and factory reset but nothing helped.
The only thing which ‘fixed’ it for me was to re-flash the SD card for my Rpi4, HOWEVER after playing a track for a few minutes the problem has come back - arggh!

Interestingly, while trying to find a workaround last night I observed a number of weird things going on:

  1. after giving up on Volumio for the evening I decided to play a track from Tidal using the Tidal app on my Google Chromecast Google TV. It played for a few minutes then stopped, saying that Tidal was already playing on Volumio. Upon starting playing using Google TV, the same thing happened again after a few minutes.
  2. I tried playing a Tidal track from the volumio.local gui but it would not play. I saw two errors pop up on two different occasions:

“Failed to open “alsa” (alsa): Failed to open ALSA device “volumio”: Device or resource busy”
“Failed to enable output “default detected output” (jack): Failed to connect to JACK server, status=17”

I hope that the devs find a solution to this soon as my trial period for Premium has just ended and I opted originally for the 12months purchase, so I can’t just decide to pay month by month

I have exactly the same issue as @charliesjc
Tidal connect was working fine about a week ago, now I get the TLS handshake error.
I didn’t change anything.

It would appear that Tidal, in an effort to hinder a handful of people who can actually make use of their leaked binaries, have succeeded in locking out their much larger legal user base.

Tidal latest Android v2.66.0 has NOT fixed this problem.

Same issue here. Tidal works fine from Windows or from Volumio itself but doesn’t work from Android.
Volumio version 3.324 (fresh installed)
Tidal 2.65.1

Solved cleaning cache, data and reinstalling Tidal from scracth. Now is working again from Android.

Same issue: TLS Handshake Fails - Latest version of Tidal on Android.

Device: Raspberry Pi 4
Volumio Version: 3.324
DAC: Schiit Bifrost 2/64
Logs: http://logs.volumio.org/volumio/a6S6u2k.html

Aug 27 17:15:56 asgard vtcs[1147]: [2022-08-27 17:15:56] [error] handle_transport_init received error: TLS handshake failed
Aug 27 17:15:56 asgard vtcs[1147]: [2022-08-27 17:15:56] [info] asio async_shutdown error: asio.ssl:336462231 (shutdown while in init)

Error Before clearing the Android Apps Data & Cache (clearing cache alone won’t fix it)
Error goes away and plays fine after.

BigManz are you saying that clearing cache AND data fixes the problem for you? I.e. basically start with a fresh instance of Tidal?

1 Like

It seems that, finally, clearing cache and data works to restore tidal connect functionality for me on v2.66.0.

It suddenly started working for me a couple of days ago and has been fine since. Before that I had cleared the android apps Cache but it didn’t help. I didn’t realize at that time I had to clear the Apps Data too.
Anyway, I just checked and my android app is at 2.65.1 so I’m wondering if I should update it or leave it alone (‘if it ain’t broke, don’t fix it’). I guess I’m going to have to bite the bullet and update it at some point so hopefully it doesn’t become broken again.