Lost folders and music

I have just finished ripping over 600 CDs to FLAC format. These plus other music that I had already was loaded onto a 700GB USB hard drive. I formated the drive using Linux (Ubuntu Studio14.04) first in FAT32 and then (when I had the problems detailed below) in NTFS format before loading all the music on it. The choice of format made no difference. The structure is Music/Artist/Album/Songs.
When I attach the HD to my Pi2 running Volumio 1.55 and rebuild the library, some folders are not there and others are empty when they should have songs. I have rechecked the contents of the HD on my Linux box several times and the files ARE there, but Volumio refuses to recognize them. I even tried to fool it by moving all of Paul Simon’s albums (it did not recognize the folder ‘Paul Simon’) into Simon & Garfunkel. I then ‘rebuilt library’, ‘reloaded’ the folder ‘Music’, reloaded the folder ‘Simon & Garfunkel’. The folder ‘Paul Simon’ was there so I ‘reloaded’ that folder too. Now all of the folder’s for Paul’s albums are there, but they are empty and ‘reloading’ reach of the folders does not fix it.
I have tried booting the Pi with the HD unplugged and ‘rebuilding library’, then turning it off, plugging in the HD and rebooting and rebuilding library. No good.
Does ANYONE have any idea what to do now?
I should note that the music that is recognised (~90+%) is great. I am using the IQaudIO DAC+ and it is really nice. I just need to find the rest of my music!
HELP!! :exclamation:

even if I doubt that it is the reason of your problems, are you sure that all folders, have the correct access right ? Because I had this problem with some music and I realised that the problematic files were copied using root as user ( I know it’s bad :open_mouth: ) . Changing owner solved the problem…

Easy enough to do ‘chown’ for main folder and subs, but WHO is owner? On my Linux box, it is Mark (me) who can Read & Write, all others nothing. When it gets transfered to RPi, I’m not sure who the user is?? I guess I could just give everybody permission. I did check and don’t see any difference between folders that display and those that don’t.

It was not a matter of ownership, but extensions! It turns out that for some unknown reason, my conversion program converted a lot of files from .wav to .flac but neglected to add the .flac extension. I had never noticed it as Linux played the songs just fine, but apparently Volumio cannot. I used a batch rename program to fix all the files and now they show up AND play. :smiley:

I had a similar problem. This seemed to be a ‘permisssions’ issue.
I had reformatted my external HDD with NTFS (I had decided to change the HDD from Ext4 format to NTFS for better Windows compatibility and ease of maintenance). I had re-loaded all the music folders and files from my PC. But, on the Pi 3+, only a few folders of the HDD were then being listed by Volumio.
To find a solution:

I put the disk back onto my PC;
clicked on the HDD disk’s folder in Windows Explorer;
in ‘Properties’, I set ALL the check boxes to ‘allow’ for both ‘Authenticated users’ and ‘Users’ for all permissions.
Volumio then found all the folders and worked properly after returning the HDD back to the Pi.