Losing contact with Volumio on RPi

Volumio Information

  • Volumio Version: 2.882
  • Hardware: Raspberry Pi 3B from Canakit, 32GB Edition
  • DAC: External USB DAC, HRT (High Resolution Technology) Music Streamer II High Resolution USB D/A Converter
  • Connectivity: WiFi connection to WiFi 6 router (D-Link DIR-X1870-US supporting AX1800) or older Wifi 802.11N router/access point on the same network as my WiFi 6 router.

For many years, I’ve played my FLAC and MP3 audio via VLC on my laptop to the HRT DAC to my stereo receiver to my Ohm Walsh 2 speakers. Everything worked fine. Since I had a Raspberry Pi 3B, I decided to try replacing the laptop with Volumio on the RPi. The sound is great, and I love being able to select songs from the kitchen table using the Volumio app on my iPhone XR. The problem is that often the app can’t seem to find my Volumio/RPi, so I have no control of what’s playing. Sometimes while I’m interacting with the app, my iPhone stops controling the Volumio/RPi, even after exiting the app and restarting the app. I’d like to use Volume on the RPi but it’s too much of a pain to lose control, which means sometimes I can’t even stop a song - I have to turn off the volume on my stereo receiver. When things are working, it’s great, like instantaneous switching from one song to another, but the unpredictability has sent me back to my laptop and VLC. Any ideas what could be wrong?

If you’re positive that it’s not your LAN wifi signal, and there are more problems than people expect with small areas of poor reception, then try using a usb wifi dongle on your RPi3, or better still a wired connection (the wifi provision of the RPi3 has a bit of a reputation for being poor).

You could also try using a browser directly, rather than the app, just to rule that one out.

Thanks. I switched my Volumio device from Wi-Fi to Ethernet. Just a few days ago, I wanted to demonstrate my speakers and again the iPhone app couldn’t find Volumio.

And your phone was still on Wi-Fi and not switched to Mobile?
You can also enter the ip in the Volumio app, so it won’t use volume.local

Yes, phone, Volumio server, and my music server NAS all on the same WiFi6 router. I’ve seen this lack of access to the Volumio server whether it’s connected to the LAN via ethernet or wifi, and I should emphasize that I usually can connect to Volumio but SOMETIMES the app just keeps searching.

Thought I did reply…
Same happening when closer to the WiFi access point, to avoid dead spots in the kitchen?

It wouldn’t be dead spots since all the other wifi devices (iPhones, iPad, laptop) have no problem with connectivity anywhere in the house.

Well, Ipad and laptops have better antenna’s than a phone…
It might even be possible some neighbor network is interfering.
I have Volumio also running on my iPhone (IOS 14.4.4) without issues, hence my questions

Did you check my earlier query about using a browser and not the Iphone app?

I have used browser and app. Fortunately, the “failure to communicate” doesn’t happen often. Thanks for your suggestions.

Sorry to repeat myself, but you are not answering the question. Do you get the same behaviour of being unable to connect to Volumio if you use a browser on whatever device, rather than the Volumio app?

I believe I was unable to connect with either app or laptop browser when the “failure to connect” occurs. It happened once last week, happened many times before, and hasn’t happened today at all. I’ve tried connecting to volumiopi.local (my host name is volumiopi) or its reserved local LAN IP address. Go figure!

I believe I answered. Same behavior with app or browser when it happens, which is SOMETIMES. Today, for example, app and browser both work.

When you lose contact with your RPi, can you see the Volumio hotspot on your mobile?

Have you also tried setting a static IP address for your RPi on your router?

chsims1: Sorry for not responding sooner. I did not notice a Volumio hotspot appear when I could not connect my iPhone to the Raspberry Pi. The RPi doesn’t have a static IP address; it has a reserved IP address. All servers in my house have reserved IP addresses, which means when send their DHCP request to my router, the router looks up the device, sees that I’ve previously reserved a specific IP address for it, and then the router returns the reserved IP address. The effect is that it always gets the same address, but the address is inside the DHCP range whereas, if using a static address, it must be outside the DHCP range to avoid contention. I’m temporarily giving up on Volumio and trying Moode Audio instead. I’m keeping the Volumio microSD card around to make it easy to go back to it, if I decide to.