Losing connection to Wifi Repeater/Booster

I have Volumio 3 running on a Rasberry Pi 3 connected to a wifi booster. It loses connection every night and will not reconnect. The only way I can get it working again is by rebooting the booster.
Other devices continue to use the booster without any problems. The booster doesn’t go into standby.
I have two other Volumio similar setups connected to the main wireless router and they work fine.
I cannot see any other post that is similar to this.
Can anyone help please?
P.S. In every other way Volumio is superb. Hats off to the developers.

Hi @TamedShrew. These are more possible workarounds rather than proper solutions.

  1. With my Linksys wifi booster, I can automate an on/off time - maybe you could do the same with yours and set it to just before you normally first listen to Volumio.

  2. Set up an auto restart on your Pi. This method requires you to use SSH and access the command line.
    sudo nano /etc/systemd/system/systemd-reboot.timer

       Add these lines (change to your preferred time)

Description=Reboot daily at 4am

OnCalendar=--* 04:00:00


     Save the file and then activate using the command

sudo systemctl enable /etc/systemd/system/systemd-reboot.timer


Thanks very much @SimonE for the quick suggestions.
I’ll give them a go after work this evening.

Setting the wifi booster to power down over night looks to have done the job. I can access Volumio this morning. It also cuts down the electric bill a bit.
I never needed to try the 2nd suggestion.
Thanks very much @SimonE for taking the time to put up those suggestions.

1 Like