lose WebUI every day, need to reboot


I’m running Volumio on a raspberry pi model b, have been doing so for over a year now and it’s been fine.

in the last month or so I find I have to reboot the pi once a day as after about 8 hours of operation I lose the ability to connect to the web interface. I can’t ssh to it either, and I can’t airplay to it.

It will still play back audio from whatever radio station it was last tuned to, so it’s working on some level, just not accepting any other sort of incoming connection.

Can you guys help? Do wireless interfaces die?

OK updating u - I put a new SD card in and flashed it with the latest build (2.whatever) - let’s see how this goes :smiley: :smiley: :smiley:

I have the same issue. Have the latest version on a rpi3. Doesn’t matter if it’s wired or wifi, give it a couple hours, connection drops off.
If i look at my router, shows an active connection, but still cant ping the ip. ?

Just a blind shot ! (Maybe 10 hours between errors !? :wink: )
Can this have something to do with DHCP address lease time ?
I have experience similar problems with other software and equipments etc. when some routers (especially D-Link routers) want’s to renew an DHCP adress it seems to happen some kind of timeout/interruption etc. and then the software/equipment loses the connection.

Reserve a address for your volumio in the router or set a fixed address

I thought of this, not sure if the op tried.
The ip is static, and shows active on the router when I can’t ping it.

Hey everyone

well after a couple of days with the new build (2.041) it was fine but now I’ve got the same problem.

My DHCP lease time is 24 hours and it definitely was working for longer than that.

I’ve now got it on a static IP address so let’s see if this stays longer this time :smiley:

PS even when I can’t hit the web UI it’s still streaming whatever station I last had it tuned to (am using volumio as an internet radio tuner for my hifi, I bloody love it)

I have installed a new image, wired connection now, and its been solid. For me at least, it seems like its an issue with the wifi.

Few weeks ago I made a plugin that solves the problem for me. You can try…
https://github.com/balbuze/volumio-plugins/tree/master/plugins/system_controller/wifireconnect. Just download wifireconnect.zip. Even if it is called wifireconnect it works with other interface…

So Im guessing this is a more common problem than I thought…

So that has solved the issue balbuze. Been up for over a day, was never been able to get that before…
Thank you very much.