Logitec Squezebox player plugin

I have not Squeezeserver set up and working and I have just installed the SqueezePlayer plugin. My music library has been recognized. I can play any file on screen but no sound coming from Volumio is well identified as the player with the correct IP address…

Am I missing something?


I found a nice and elegant solution. The application “Lumin” is connecting to Volumio via the Squeezebox server…

All my library and AIFF tags are now recognised. Perfect!


I have found the solution. I had to change the output to my DAC and not to ALSA in the plugin settings. It works also from the Slimserver web interface.

Great! AZnd cherry on the cake, QOBUZ plugin is working…


I just installed this and after a reboot or two it is working perfectly. Awesome! Thanks Saiyato!

I have purchased the Ipeng App and this is working now beatifully with Volumio. I need nothing more…


I have installed the Logitech Squeezebox Player Plugin and after I have changed the output device to one of the HiFiBerry DAC Plus devices it works perfectly. The only problem is when I want to use Volumio UI for playback I have first to switch off the Squeezebox player (or to switch off the Plugin) otherwise I get an error telling the device for playback is busy. It is not enough to stop playing on Squeezebox player. Otherwise, when playing from Voluimi UI and starting playback with Squeezebox Player I just have to stop playback on Volumio UI and playing from Squeezebox Playes starts. Is there any posibility to make this switching automatically when stopping Squeezebox playing and starting playback on Volumio UI? Squeezebox player should give free its output device when not playing. Maybe this can be done by adding a stop button to Squeezelite player?

Have you tried selecting the dmix device?

Just tried, does not work for me. What should be the difference?

The way the soundcard is called, it’s all supported, you might need to read into this. It’s not something I can easily fix for you.
Maybe the plughw mode is even better, depending on your setup.

The way the soundcard is called seems to change nothing for me. But this is not a big problem, just switching the sqeezeplayer off when leaving, and the plugin is awsome anyway!

nice work squeezeplugin works fine :smiley:

I have installed the Squeezelite player plugin and activated it, and restarted volumio, but I don’t see any change at all. I have also changed the output device settings to every selection and some will play music in volumio as usual. Others give the error: Failed to open “alsa” [alsa]; Failed to open ALSA device “hw:1,0”:Device or resource busy.
Is there supposed to be some obvious evidence of a change in the player? Shouldn’t I see some listing of the media being served by LMS on my Win7 computer. The LMS web control panel on my win7 computer does see the “Volumio” player, but I see no evidence in volumio that squeezelite is active or able to see the LMS library media.

I am trying this because the volumio set up of Network drives is far too complex for the average user and I’m trying to find a simpler way to use my wifi to play music from my computer drives. I was hoping using squeezelite on the RPi and LMS on my win7 computer would do this.
Am I expecting the wrong results here?

Thanks in advance ;^)

Hello everyone!
I downloaded and installed volumio-squeezelite-plugin.zip file. In squeezlite player settings i get “No Configuration Available”.
In settings Logitech media player i got “Your player was not found”
Did I do something wrong?

VERSION: 2.657

Hi both,

If the you see ALSA errors, try using a dmix device instead, this is the same as with the piCore player, you just need to select the correct output device.

As for no configuration, this sounds like an installation problem, on what platform are you running? I just tested this for you and it works on my Pi3B right out of the box, when installing from the plugin store.

Hello, thx for Your answer. My platform is pc. I thing i’m wrong installed plugin. How to correctly install this plugin from github on volumio terminal? Could You like to past here all command (step by step) please? Forgive me i’m a linux newbie. Best Regards.
When i try install i get error:

volumio@volumio:~/master/volumio-squeezelite-plugin-master$ volumio plugin install

This command will install the plugin on your device

Compressing the plugin
No modules found, running “npm install”
npm notice created a lockfile as package-lock.json. You should commit this file.
Plugin succesfully compressed
/bin/mv: target ‘/tmp/plugins/squeezelite.zip’ is not a directory
throw err;

Error: Command failed: /bin/mv *.zip /tmp/plugins/squeezelite.zip
/bin/mv: target ‘/tmp/plugins/squeezelite.zip’ is not a directory

at checkExecSyncError (child_process.js:601:13)
at execSync (child_process.js:641:13)
at install (/volumio/pluginhelper.js:688:9)
at Object.<anonymous> (/volumio/pluginhelper.js:749:9)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Function.Module.runMain (module.js:693:10)



Just received my Volumio Primo (Volumio version 2.699) and installed Squeezelite Player (1.1.1) plugin.
I also installed LMS plugin as well but when starting it I couldn’t find Squeezelite player.
Tried to go to Squeezelite Player Plugin Settings but I get “No Configuration Available” message so no way to select a specific audio output.

I read on other posts that is generally down to plugin install issue, so tried to uninstall/install few times, but still the same result :cry:

I’m a complete noob so I have no clue how I could install plugins other than via Volumio UI for the Primo.

Any idea what could be wrong there ?

Thanks in advance !

Hi there,

I don’t think the Squeezelight binary is ready for x86, that’ll probably explain.
You could try to recompile, the source should be on Github iirc


Hello @saiyato I have two questions:

  1. I am using volumio squeezelite plugin, I use Tidal from there. I want to know if when I play in Master quality it does it in 24 bits as it does from Volumio.
  2. At home I have a PC connected to the network by cable and a notebook connected by Wi-Fi. LMS from the PC works correctly, I see Volumio as a player. If I install LMS on the notebook I don’t see Volumio as a player. Some explanation?
    Very grateful for the attention.

Hi Daniel,

By default the squeezelite process will look for servers (if not specified explicitly using the -s parameter) and connect to the first one it discovers. This means it will not automatically show up on new instances of LMS. You’ll have to point the process there with the -s parameter:

-s <server>[:<port>]  Connect to specified server, otherwise uses autodiscovery to find server

See: this page

Thanks @Saiyato, I solved point 2). What can you tell me about point 1)?