Local web UI on Volumio 2 for RPI

I have found confliciting information regarding this. So i’ll jsut ask here:

Is it possible to activate the local web UI on Volumio 2 for Raspberry Pi?

I thought it was part of the product and after installing it on a small x86 machine I went ahead to my RPi 3 just to see there is no local UI. I need one, though. Since Kodi runs quite nicely on the machine I see no reason why there should be not enough brainpower in the little machine.

Is there a simple way to activate the local UI or is it simply not there? Are there any alternatives?

Go to settings -> PLugin, install the touchscreen plugin

Thanks, but that does not appear to work. I have installed the plugin and rebooted. I still only get the console.

What display (brand and model) do you have and how is it connected?

It is a Kuman 7 Inch HD 1024*600 TFT LCD Screen connected via HDMI.

Just to confirm: Is it this one http://www.kumantech.com/kuman-7quot-tft-lcd-capacitive-touch-screen-hdmi-1024600-for-raspberry-pi-3-2-model-b-rpi-1-b-a-bb-black-pc-sc7b_p0024.html?

In a first step please post the results of cat /boot/config.txt , cat /boot/userconfig.txt and systemctl status -l volumio-kiosk

Please provide some information if you have installed software for the display and what it was in detail.

Thank you for your reply. It is in fact this model:
amazon.de/gp/product/B01FFA … UTF8&psc=1

I have not installed anything but the Volumio image and, after you suggested to do so, the touchscreen plugin.

Here’s the requested output:
cat /boot/config.txt:

systemctl status -l volumio-kiosk

userconfig.txt appears to be empty except for one comment.

Ok, please add the following lines to your /boot/userconfig.txt: hdmi_group=2 hdmi_mode=1 hdmi_mode=87 hdmi_cvt 1024 600 60 6 0 0 0and reboot.

Still no luck. Again it just boots into the console, asking for user/pass.

Did you enable the touchscreen plugin? From what I see it’s not enabled

Good thought :wink:

Hah. That easy? Crazy.

I am sorry, I did not realize I’d need to activate the plugin. I thought rebooting after install should be enough.

Thanks a lot for your help.

Now the mouse pointer is not showing up. It is there, I can see MouseOn but no pointer. I found plenty of information on how to remove the pointer but not on making it appear. Sorry, this is about where my ideas end when it comes to linux. It’s been twenty years since I last lived with this OS.


And I thought after the installation process of the plugin had finished you were asked if the plugin should be activated… and did not consider this could have been negated.

Good to hear it works now!

When you enter the plugin’s configuration page look for a section “Mouse pointer settings” at the bottom of the page. There should be a switch to en-/disable the pointer. It is disabled by default.

Thank you.