Loading screen with spinner prevents access to web interface

Hello, I am new to and excited about volumio. I have limited experience with *nix, single board computers and digital audio. I have installed volumio 2 version 0.979 on a raspberry pi 3 with a HiFiBerry+ clone DAC. The hardware, including wireless networking, the webserver and DAC appear to be working.

When I attempt to access the volumio at volumio:3000 I can see the web interface but it is masked buy a dark box and a “spinner.” (see attachment) I can reload the page, use a different browser or machine, restart mpd, the result is the same.


The problem seems to be similar to the one described here: https://volumio.org/forum/web-interface-masked-frequently-connecting-overlay-t2926.html. However, the proposed solution seems to be for an earlier version of volumio and the referenced file does not seem to exist in this version.

/var/log/volumio.log doesn’t appear to have any pertinent information in it but I’m happy to share whatever might be helpful. I must admit I’m at a bit of a loss. Thanks in advance for any help or ideas.

Just to know ;
Why do you need to access port 3000?

As far as I can tell, port 3000 is the location of the default volumio interface. Port 80 doesn’t work at all.

Ok, The suggestion here https://volumio.org/forum/connection-refused-volumio-raspi-after-updating-t4596.html by Torsten seems relevant.

If I edit local-config.json to reflect the rpi’s IP address, I can get into the interface. This workaround seems less than optimal as the device is getting its address via DHCP…

Other ideas?

I think we’re getting something wrong with IPtables rules not being loaded…

Could you paste the output of :
sudo iptables --table nat --list

Yes. It looks like this:

[code]sudo iptables --table nat --list
target prot opt source destination

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

target prot opt source destination

Are you connected with wireless or LAN?

I’m connecting wirelessly, encrypted network, hidden SSID. When I set it up initially, I didn’t know about the initial hotspot and configuration of wireless, etc. through the web interface. I connected a monitor and keyboard and edited /etc/network/interfaces by hand to get the wireless working. I’ve made any subsequent changes over ssh.

Ok that’s a hint. So probably, what’s happening here is:
your manual configuration prevents the NAT rules from being loaded properly (they get loaded when a network interface is brought up).
You can solve by adding :

iptables-restore < /etc/iptables.rules

To rc.local or any other autostart method

For more info, look at what happens when an interface is brought up here:
github.com/volumio/Build/tree/m … f-pre-up.d

Thank you, kind sir. And thanks for volumio. I will let you know what happens.

A followup to my manually mucking about with system settings and breaking stuff:

I did a “factory reset” from the “system settings” page. I was able to easily connect to the hotspot, change network settings and everything worked exactly as it should. Thanks again michelangelo, et. al.