Library won't fully update.

Good evening,
Super noob here, got a real stumper.
I’ve got a decently large (160gb) music library shared from my Mac over samba to a rpi b+ running the latest volumio. Everything works great over AirPlay. But, when I browse through the nas connections, volumio will only display a quarter of my library. It stops in the “L’s” at first I thought the folder just hadn’t update fully, but it’s been running for a week nonstop and it still doesn’t get past the L’s. I’ve tried using the update library button as well as the update folder under the nas tab. With no luck. Now, am I missing something? Is this a limitation on the smb share? Does mpd need this much time to update a share? Any help with this would be great. I really want to use this to its full potential.

this forum is quiet but I understand your position.

As a noob myself, you could do a count of your files up to ‘L’ and if the figure is 10,000 then you have hit a long-standing file number limitation in volumio. Would that be it?

There is a good chance that could be the issue. Thanks for your reply.