Library missing songs/artists

Good afternoon,

I have found that some songs/artists won’t show up in the library.

I think there are two issues at hand here, one has an error in the log:

  1. id3: Failed to read RIFF chunk > this should be resolved in mpd 0.19.x (I have updated the mpd client, but to no avail, maybe I’m doing something wrong here?) > link to issue:

  2. no error found in log, but for example the directory ‘Alizée’ was not indexed, maybe because of the ‘é’ in the directory name?

I love to help and/or debug if you don’t have the time for it. I kinda do need some directions though :unamused:

Please let me know if anything is unclear or if I need to provide additional information. (Or if I should only test in 2.0 for example.)


Raspberry Pi B2/B+/B (have tried all three)
Volumio 1.55 image (have tried the 2.0, but the RC1 seemed unstable in my setup)
Music is on an NFS-share (Windows Server 2012R2)
Network connection is wired
No upgrade/dist-upgrade/rpi-update has been performed

We have seen similar issues with mpd failing to scan tracks with corrupted embedded album art.

Not entirely, since my problems also exist in volumio 1.55, whereas the mentioned problem only occurs in RC1.

I do have album art embedded though, but as seen above, it did work in 1.55 for that person.

I just installed the volumio 2 (0.86) and the problem persists.

MPD version is 0.19.9

If I can do anything to help fix this issue, please let me know :slight_smile:

Could you log it as an issue on the GitHub Repo?

We can track it properly then.

Sure, just did this: