Issues with I2S DAC

Volumio Information

Volumio Version: (not sure)
Hardware: Raspberry Pi 2
DAC: ES9023


I’m new to Volumio and I’m comming From RuneAudio (due to it’s discountinued support and lack of features). I have a hardware consisting of Raspberry PI 2, ES9023 I2S DAC, Arduino Nano, 20x4 LCD display, USB hub, Wi-Fi adapter and power supply. All this was working very well with RuneAudio and mostly continued to work when I tried Volumio with all the hardware connected “in the air”. Then I decided to build a housing and integrate everything inside but after that, I was not able to get the DAC working anymore. After further investigation, I discovered that I made a mistake with connections and that I sent +5V on the DAC where I shouldn’t. Since it wasn’t working even after I fixed the connections (just some noise and occasional distorted sound), I concluded that the DAC got destroyed so I ordered a new one, exactly this one:

But I can’t get it to work at all. I tried all configuration combinations with multiple reboots between testing but no success, there’s no sound from the DAC (except some humming) at all. The 3.5 mm output works fine. I tried to format my SD card and install Volumio from scratch but without success.

What am I doing wrong? Which configuration should I use for this DAC? Does anybody have a correct schematic for Raspberry Pi 2 and this DAC? I was struggling a little bit with finding the correct pins and I think that one of the pins on DAC remained unconnected but I read somewhere that it’s not needed for Raspberry Pi.

I also asked my friend to borrow me an oscilloscope to test if the signal is coming to the DAC at all but first I would like to make sure that all connections and settings are correct.

Thank you in advance!

Is wiring like that :

I will double-check as soon as I get a multimeter but I’m pretty sure that it’s wired like this. There’s a Raspberry Pi model B on the image. Does it have the same pinout as RPi 2? Also I’m pretty sure that it’s the MCLK that left unconnected in my case as well.

If the wiring is the same as on the image, where else could I look for issue? What about the profile setting in the Volumio configuration? At last, I guess that I should be able to check if there’s a signal on the DATA pin with oscilloscope?

Have tried generic I2s Dac?

Yes, I think that I tried most of them (if not all). And at first (when I connected everything just with wires in the air) I got it to work but after I finished everything and put it in the housing, it just stopped working.

In fact this is rather “hifiberry Dac” that should be selected.

OK, I finally managed to get some tools and a multimeter to investigate this. I also borrowed an oscilloscope from my friend.

tl;dr: it seems that the there’s a hardware issue with the I2S output on the Pi.

tl;dr2: how is the performance of USB sound cars on Pi2 and Volumio in compare to I2S DACs? Buying a new Pi is not the best option.

So I first checked and confirmed that all connections are as on the above provided link. But to be sure, I removed all the wires and connected DAC directly to Pi with jumper wires. I also made sure that the DAC board is getting power supply properly and that all 3.3V regulators on the DAC are working.

Then I connected one probe of oscilloscope to the DATA in on the DAC board (connected to pin 40 on RPi) and another probe to the audio out. At this point, it seemed to me like the DATA is working fine because it would change as soon as I would play something (I’m not good with reading oscilloscopes but I can spot the difference :smiley:). I tried many profiles (Generic I2S, Hifiberry DAC etc.) and with both software volume control and none. The output of the DATA was always the same (which was a little bit weird) and there was no audio no matter what I’ve tried.

Then I remembered that I recently got the Arylic Up2stream Mini V3 board which also has an I2S output so I connected this DAC there and voila, it was working fine. The Arylic has a MCLK which RPi is missing but it works with or without this one connected. So the DAC is fine.

Then I tried to format the microSD and set-up Volumio from scratch. No help. At last, I’ve tried RuneAudio (because I was using it prior to Volumio with that same Pi and DAC and it was working fine for more than a year). But I got the same result, the same DATA output as on Volumio and no sound.

This leaves no other options but a hardware bug with the Pi. Is there anything that could be done here?

For reference, the I2S audio DATA from Arylic Up2stream board looks like this:

And the I2S DATA from Pi (both Volumio and RuneAudio) looks like this: (just link because I don’t have permissions for more than one image)