Issue with File Upload via sFTP [RPi]


Volumio runs great and smooth on my RPi but i have found one little issue.
When i try to upload new music via sftp, the file transfer stucks on every file (files >30MB - FLAC)
In the end, the transfer is succesfull at all, but it takes much time when it stucks. Sometimes it´s even necesary to reput the file
“Status: reput: restarting at file position 21004288”

This problem occurs over wifi and cable.

Anyone else whith this problem?
Any ideas for solution?

Thanks a lot.


Ok i found a solution that works fine for me.
I tried around with sftp,scp and samba. Finally samba worked best.
I think its because encrypted transfer such as sftp and scp are resulting in very heavy processor load. On Pi-side this results in low transferrates caused by Pis slow processor. So samba is best for this.

If you are using windows, Just type “\your.pis.ip.adress” in the file-explorer.
USB drive on pi will act as an regular directory in WindowsExplorer.

So for me: This is the best solution to transfer new music files and playlists to Pi without unplugging (and unwiring :wink:) the USB-HDD.
Also i format the HDD in ext4 for best performance on linux, but i will try Fat and NTFS tomorow for better compatibility.