Isolated sound card requires Pi kernel version 5.4.58 or later

does it work with it?

I ended up adding the soundcards to the DACs json file. I’ll wait till that is properly integrated and check.
If both of these kernel versions are post 17th of July 2020, then it will work.


Nice to meet you, Matt.

I’m one of the people who helped the Isolated Soundcard (Kickstarter) created with your new ideas.
It was delivered by September 7th, and I installed the latest version of Volumio (kernel 4.19.118-v7 + # 1311 Apr 27 2020), but it is not the post 17th of July 2020 you pointed out, so I2S DAC It cannot be selected because there is no Audio injector-isolated-sound from the menu. The only solution is to wait for the new Volumio update version in the future.


Nice to meet you,

Support for the high end Audio Injector sound cards was just added to Volumio:

So I think you’re right, the next Volumio release will include support for the Isolated soundcard.

I have looked to see when the next release will happen. I’m not really sure where to look.


Today, the latest version of Volumio (2.834: Thu Sep 24 22:22:43 CEST 2020) has been released. I installed it on the Audio Injector Isolated Soundcard with Balanced Breakout on the HAT of the Raspberry Pi 4B.
From this version, I can select Audio Injector Isolated Soundcard from I2S DACs, but I still can’t play sound by selecting Internet Radio.
Even in this version, kenel is the same as Volumio 2.806, so I think that is the cause.
I would appreciate it if you could tell me how to make it work properly.

Nice work !

I am aware of this problem, have a look at this post here : Audio injector Isolated card needs modprobe for Linux version

Until Volumio starts using the current Rasperry Pi kernel (version 5.x.xx) the following has to be run after booting :
sudo modprobe snd_soc_cs4271_i2c

Alternatively you can create or edit the /etc/modules file and add the following line :slight_smile: snd_soc_cs4271_i2c

I just did a test of this setup. Here is how I did it :

Open ssh access

In the browser go to volumio.local/dev
Click “enable” under the ssh label.

Login to volumio using ssh

ssh volumio@volumio.local
Use the password volumio

Add the snd_soc_cs4271_i2c module to the modules file

echo “snd_soc_cs4271_i2c” >> /etc/modules



Once rebooted, it should now work.


Thank you for your quick advice.
I followed the advice and added the command exactly as it was, and then the internet radio played with great sound. I am deeply grateful.
By the way, I got two Audio Injector Isorated Soundcards, but I can’t play one of them. The Isoration transformers gets unusually hot (can’t touched by hand!) ,and no sound is played. I will email you again in detail about this issue on your site.
Anyway, the Volumio-Audio Injector sounds really great.


ok - that heat doesn’t sound good. Contact me offline to discuss more if you like.

Hi Matt

For the defective Isolated sound card, I will reply with details on the Kickstarter site.
I have found an apparently unusual phenomenon with an Audio Injector Isolated sound card that can play sound, so I would like to report it.

The audio pitch is clearly different. I confirmed that the time pitches are different by playing almost simultaneously using Allo Digione Signature.
The Audio Injector Isolated sound card has a fast time pitch. The audio is shifting to the treble side.
Please check.


Oh ok - sounds like volumio isn’t doing sample rate conversion.

I assume you were playing a 44.1 kHz piece of music ?

Sounds like you need to use the plughw ALSA device instead of the hw ALSA device.

I’ll look into how to change to plughw in volumio.


Oh I can see the setting you need in the settings->playback options menu item :

At the bottom, enable “audio resampling”

You can play with the features, I think the best solution is 32 bits, very high quality.
96 kHz or 48 kHz depending on your needs.
As long as the Pi can handle the high sample rate and “high” or “very high” rate conversion, everything should be good.

I have understood how to solve the audio pitch.
I will retry the micro SD card from the initial settings.

Now I have a question about a hardware issue.
Currently, I am using a balance breakout board as a HAT, but the relay that prevents pop noise does not work stably. I don’t know if it’s a DC offset issue, but the relays turn on and off irregularly. Depending on when the power is turned on, no sound can be played.
I would appreciate any advice.



I am also wondering if there is a DC voltage issue with the power supply.
Is there a red LED light constantly on for the Pi? I believe that the red light turns off or flashes if the voltage goes below 4.63v. the relays are 5v relays.

I would also like to check which driver version is running on this volumio release. There was a mute relay software change after the first driver commit.


HI Matt

Again, I’ll sort out the bugs with my Audio Injector Isolated DAC at this point.

(1) The audio pitch is clearly different.

When I was playing a 44.1 kHz piece of music, I confirmed.
This solution can be solved by using plughw ALSA device instead of hw ALSA device.
Is this correct?
Also, can this change be changed in the current Volumio version?

(2) When the Raspberry Pi is started or restarted, the mute relay often does not turn on normally.

Yes, my Raspberry Pi 4B is a red LED light constantly.
Therefore, I don’t think it’s a problem with the power supply voltage of the Raspberry Pi.

Well, after that, what I confirmed.

I used one normal Flatmax ISOLATED (v1.21) and replaced two Balanced Breakout (v1.15) boards and two RCA Breakout (v1.15) boards for a total of four HATs. I have confirmed that all of the above problems occur in the same way.


Regarding mute problems. I think these problems will go away once Volumio update their kernel to a newer version : 5.4.58 or newer.

Regarding the same rate issues, did you try to “audio resampling” approach I wrote about above ?

The mute problem will be solved when the Volumio kernel becomes 5.4.58 or newer. I understand.
If the relay turns on normally, there is no problem with continuous playback.

Yes, for sample rate issues, playback options, you recommended
I saved it with changes and checked the playback sound.

Audio Resampling: On
Target Sample Rate: 96KHz
Resampling Algorithm Quality: Very high

Hi, IMHO there is a new addition you can make to the configuration of the DAC to make it work with curerent kernel (5.x won’t come soon, too unstable at the moment).
See for example this commit:

Darmur added a script to initialize the DAC. You can do the same to mobprobe the module you need

Rasbian ships with kernel version 5.4.xx right now. It is more outdated and unstable to be on a less progressive kernel.

I am concerned that this mute bug fix I submitted to the Pi’s Linux kernel is not in the current Volumio kernel … if that is the case, the Volumio kernel is more then 3 months old.

We prefer to have stability rather than being cutting edge.
Kernel updates usually break lot of stuff, especially i2s DACs, so we want to be 100% sure that everything works when upgrading. We can’t just upgrade for your DAC, risking to break support for other DACs. From our latest tests 5.xx was breaking quite some stuff.
I suggest to apply the fix I suggested