Is it possible to clone an existing Volumio setup?

I want to add more Pis running Volumio to other rooms. I would like to avoid the time and work of having to install all plugins and going through setting up all custom settings on each additional Pi.

Is it possible to take the SD card that already has a good working setup of Volumio (inlcuding installed plugins and settings) and clone it for use in additional Pis, without conflict of IP address, Device Names and so on?

I always use ApplePi-Baker for mac, maybe there is also an ApplePi-Baker for windows.
you only have to make a backup image once and you can burn it to any new sd card with ApplePi-Baker.

If you use a Linux pc
Insert your working as card
In a console type


to see it name (something like /dev/sdx)
Now type (of course, adapt the name)

df if=/dev/sdx of=myvolumioimage.img be=4096

Now you have a image you can write on other SD.

@balbuze if you clone a card you will have a copy but the 2 clones will not see each other.
so running clones has disadvantages

Yes @dvo, that’s the problem I ran into when I tried. To work around it, I tried changing the Player Name and Wired Network to automatic so that I get a new IP then restarted the cloned Pi. It worked fine with new IP.

When I started up the original Volumio Pi (while the cloned Pi was running), I noticed that none of the Pis displayed or detected the multiroom devices. Snapcast plugin did not show either of the devices as an option for Volumio Host for snapclient either.

Is there any other solution for this?

Or is there a way to copy installed plugins and settings without having to manually install and setup on each additional Pi?


On a new pi with cloned image, try :

 rm /data/configuration/system_controller/system/config.json

and reboot

1 Like

ok Thanks @balbuze. I’ll give that a try a little later today.

Under Windows, I use Win32DiskImager for creating and writing images of an existing Volumio system.

1 Like

Thanks @Darmur and @balbuze

@balbuze your code work to allow me to keep the plugins and settings but after running the code, snapcast server stopped working. It was working fine before I ran the command.

Any fixes to get snapserver working again?

This is the portion of the log with the error:

/bin/sed: couldn't open temporary file /etc/sedAH1ZHh: Permission denied
info: Could not clear config with error: Error: Command failed: /bin/sed -i -- '/#SNAPCAST/,/#ENDOFSNAPCAST/d' /etc/asound.conf
/bin/sed: couldn't open temporary file /etc/sedAH1ZHh: Permission denied
info: Cleared previous asound config
info: CMD: /bin/sh /data/plugins/miscellanea/snapcast/
info: Successfully executed script {/data/plugins/miscellanea/snapcast/}
Exception in StreamSession::reader(): read_some: End of file
daemon terminated.