IR remote not working correctly with Tidal connect

Is there any update to this topic? In detail, is volumio working on a fix for this (different behaviour of MPD and volatile sources)?

A fix is needed if something does not work as specified.

Volumio does not claim to support a remote control.
Remote control has been developed as a community plugin.
When this plugin does not work with volatile sources like Tidal, then should the Volumio team “fix” this?
I believe not, instead there should be a feature request to support IR commands to be passed on to relevant play plugins.

Thanks for clarifying. I fully understand that.
But, in my understanding the described issue is not related to the ir remote (or the plugin) but to the “volumio play” command (dependent on the currently using service, here tidal connect). And this is not working as expected. So, lets think about the case that someone only uses volumio implementations (REST API and tidal connect). When tidal connect is paused and you trigger volumio play through rest api it will not work. That was the backgound of my question.

Sry, maybe this thread was the wrong one to ask this. I just wanted to know if there is any work on this.

Regarding the IR remote plugin - ever since I updated to Volumio version 3 (currently on 3.179) I don’t have the IR remote plugin at all any more.

Migrating from version 2 to 3 basically does a fresh install, however the IR remote plugin doesn’t seem to be in the list of available plugins that can be installed.

So the play button not working correctly is a moot point to me now that I don’t have the plugin at all.

Is this plugin no longer endorsed or supported ? (I’m assuming a plugin must be endorsed by the Volumio authors to appear in the available plugins GUI)

Can it still be installed via the command line ? I’m kinda missing it… I assumed it might have been an oversight on the first release of version 3 but I’ve updated twice since then and it has not made a reappearance in the list of available plugins.

I don’t think there is. To make sure the devs have at least a look at your issue, you should put in a feature request

Ask the author, I can’t advice anything else.

The IR Controller plugin is still pending for approval:

You can follow the status of plugins for Volumio 3 here.

The fix is contained in the Volumio backend code, and isn’t plugin specific.

The root issue is that the API exposes a different method for volatile and non volatile services. Having the API caller keep track of which service is currently active isn’t very efficient.

There should be a PR from me a few years back with a fix that never got merged, someone inclined can cherry-pick, resolve conflicts, and resubmit the patch to the new repo.

1 Like

Apparently this was already fixed on 22 Dec 2021.

Exactly. Unfortunatly the current release Volumio 3.179 does not carry that fix. Probably some merge conflict over different releases.

I manually changed the /volumio/app/index.js source file accordingly to the fix above from ashthespy and it works fine now.
Just map the play/pause remote’s button to “volumio toggle” command in order to have a proper behavior with both Tidal Connect and Spotify Connect .

@volumio , could please check and validate the fix here linked for an official next release ?


VERSION: 3.179 RELEASE DATE: 20-12-2021
That release is a few days before the commit, it should automatically be picked up in the next “stable” release :slight_smile:

Hello All,

Just installed the v3.197 on x86.

Volumio toggle command is now working properly, at least with tidal.

Really thanks!


I just updated to v3.198.

Kind of amusing to see in the release notes, “Fix for resume with remote control”, when the remote control plugin is still not officially in the available plugins list even in 3.198… :rofl: So only people unofficially installing it will see this benefit.

I guess it’s time for me to manually install the IR plugin from the command line and see how it’s working now with the play/pause fix.

It’s unclear to me what this fix actually does, because the play button on my remote (mapped to /usr/local/bin/volumio play in the lircrc file) still stops Tidal playback and starts playback of local media.

So nothing seems to have changed. What did I miss ?

volumio toggle seems to pause and play Tidal, but I think it did this before and it is not even mapped to any buttons in the Xbox 360 profile I use.

I don’t particularly want to remap my play button to call volumio toggle (I’d have to manually edit the lircrc file which will get overwritten on every update) and I think there are cases when playback is not running where the toggle function will not work when the play function will.

The fix is only for toggle from what I see from the code… It doesn’t fix pause and play at first glance.

Well that’s a pity. Remapping the play button on a remote which has dedicated play, pause and stop buttons (like the xbox 360 profile) to toggle is not a good option for a few reasons.

I agree, guess we shall wait for clarification from the devs - I had a very quick cursory glance at the code, and could be wrong.

I just checked and there isn’t even a button mapped to volumio toggle in the Xbox 360 lircrc profile, although some other remote profiles do have it on strange buttons - for example the Xbox One remote profile has toggle mapped to the OK button.

I actually created the xbox 360 profile but at the time there wasn’t any logical candidate button for the toggle function to map to - and no apparent need for it since there are already dedicated stop, play, and pause buttons mapped which all worked perfectly prior to the implementation of Tidal connect. (The xbox 360 profile predates Tidal connect by quite a while)

I could update the xbox 360 profile to map OK to toggle as well but that seems like a bit of a UI mess to have to remember to press OK not play when using Tidal connect.

I hope some unified solution for this can be found - for now I’m going to adjust my local lircrc configuration to send toggle not play when the play button is pressed and see how that goes.

Stop and pause buttons already work OK with tidal connect, with the pause button working normally and the stop button disconnecting the tidal session, which seems like reasonable behaviour as it allows you to escape the tidal connect session and then start playback of local playlists without having to reach for your phone to cancel it from there.

I’m quite certain my patch from 2020 could handle play/pause as well as toggle.

There’s probably some other reason the current pure toggle approach was chosen? Not sure if github or here is better to get dev eyes on it though.