IR Remote Controller Plugin: How to get it work (with Apple A1156)?

Hi all,
I was trying to get it work a view days ago, but after hours of trying to reinstall, reboot and changing config files I gave up. Now I want to give it one more try - with your hlep :slight_smile:

My Setup

Volumio Information

Volumio Version: 2.853
Hardware: Raspberry Pi 2 Model B / a01041 - Rev. 1.1
DAC: HiFiBerry DAC+


What already works

  • If I run the command sudo mode2 -d /dev/lirc0 I can see that, that the Pi already reacts to singals from my Remote.

Here is an example ot the output:

volumio@volumio:~$ sudo mode2 -d /dev/lirc0
    [sudo] password for volumio:
    space 16777215
    space 404552
    pulse 8992
    space 4575
    pulse 540
    space 637
    pulse 526

What does not work yet

  • Volumio does not react to signals from my Remote.

What I have already tried

  • Restarting Raspberry/Volumio.
  • Uninstall Plugin, Reboot, Install Plugin, Reboot
  • Changed the Config for the remote with one from sourceforge. Gave it a try because it helped here: Help with IR Remote Controller

Any help is appreciated!

The sourceforge lircd.conf will not work without modifying the ‘begin codes’ to match what volumio is expecting:

Not the hex values, just the codes.

Depending on what functionality you want of course, but I replaced:


Such that my lircd.conf begin codes look like this:

begin codes
end codes

Thanks for your reply schliden!

Unfortunately after a reoboot, my changes are reverted.

For edititing I use these commands:
cd /etc/lirc/
sudo nano lircd.conf

I used the config from sourceforge ( with following changes:

  • name Apple_A1156 —> name irremote (also gave it a try without this modification)
  • copied the begin codes from the origninal volumio config to replace this part in the sourcefoge file

So here is the lircd.conf file I try to use:

# this config file was automatically generated
# using lirc-0.8.1(iguanaIR) on Fri Mar 30 19:20:40 2007
# contributed by Matthias Urlichs <matthias|>
# brand:                       Apple
# model no. of remote control: A1156
# devices being controlled by this remote: new (late 2006) MacBook
# This config files are for non-Apple receivers only.
# Use the lircd.conf.macmini file when you are using the Apple receiver.

begin remote
  name  iremote
  bits            8
  flags SPACE_ENC
  eps            30
  aeps          100

  header       9065  4484
  one           574  1668
  zero          574   547
  ptrail        567
  repeat       9031  2242
  pre_data_bits   16
  pre_data       0x77E1
  post_data_bits  8
  post_data      0xC5
  gap          37600
  toggle_bit      0
  ignore_mask 0x80ff

      begin codes
          KEY_RIGHT                    0xE0
          KEY_LEFT                     0x10
          KEY_UP                       0xD0
          KEY_DOWN                     0xB0
          KEY_PLAY                     0x20
          KEY_MENU                     0x40
      end codes

end remote

Why does volumio replace the modifed config afer a reboot?

In case this is because volumio thinks the config is invalid - @schliden would you share your config file here?

OK, now if figured out the issue.

I was modifying the wrong lircd.conf file.

After modifying the file
/data/plugins/accessory/ir_controller/configurations/Apple Remote A1156/lircd.conf
it worked!

I modified it like described in my post above.

@volumio would be great if this second type of the A1156 would be implemented in the plugin.

Just send a pull request with the required files and we’ll add it.
If you don’t have a GitHub account, post here files correctly named.

@balbuze thanks!

Unfortunately I don’t have a github account.
You can find the file which is working on my side here: (654 Bytes)

Had to zip it, because otherwise upload here was not allowed.

So, if I understand, there two kind of Apple A1156, right?
So we need to name it in the list so that to be able to recognize it.
Apple Remote A1156
Apple Remote A1156 (new) ?
Or what?

For me it looks like there are (at least) two kinds of A1156.
Since I bought my remote second hand, I can’t tell you if I’ve got an older or newer version.

My Suggestion:

  • Apple Remote A1156
  • Apple Remote A1156 - alternative

Ok I’ll have a look

I updated the plugin to Version 1.2.5

  • Added alternative Apple A1156
  • French translation
1 Like

@balbuze wow - you were fixing it faster than I could test it :smiley:

I uninstalled the Plugin, made sure that my modified file was deleted and installed the updated version.

–> I can confirm that it works now out of the box.


@oha Your lircd does not have the same codes as mine…

Please see attached: (804 Bytes)

@leigh_telles This might help you in your quest…

@schliden i compared our files. Only the notation is different.

I’m pretty sure the latest plugin version will work on your side to! :slight_smile: :+1:

Im having very similar issues with the Apple Remote A1294.
I have the receiver on 3,3v - ground - GPIO25
Reinstalled the Plugin and restarted the pi several times.
Like user oha I get feedback in sudo mode2 -d /dev/lirc0 when i press buttons on the remote but there is no reaction in volumio whatsoever.
Do you have any hints? Did I miss something?

Thanks in advance!

I am using Apple remote A1156 with a TSOP38x IR receiver, same connections as you have.

My only suggestion is to double check the installed/configured lircd.conf and lircrc files which should be somewhere like: /data/plugins/accessory/ir_controller/configurations/Apple Remote A1294/’

Make sure that the begin code names in lircd match the button names in lircrc etc.

It might not hurt to re-select the correct plugin via the web interface:

From volumio web interface: Plugins > Installed Plugins > IR Remote Controller > Settings > Select “Apple Remote A1294” and save.
Restart Volumio

Good luck…