IQaudIOCODEC -IQAudio PI Codec Zero

Hello
just installed a PiCodec Zero. cant find it on the list of I2S devices
aplay command finds the device
any idea on how to get volumio to see it as a playback option
thks

volumio@pi0-iqmonoamp:/boot$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: IQaudIOCODEC [IQaudIOCODEC], device 0: IQaudIO CODEC HiFi v1.2 da7213-hifi-0 [IQaudIO CODEC HiFi v1.2 da7213-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Ive bought one of these as well for a small project. As the Raspberry PI details listed Volumio, (for the other IQaudio board I suspect) I was hoping it was going to be straightforward.

Looks like quite a neat little board. Although all Id like at the moment is AUX out.

OK. It works!

Not sure how much of my fiddling was necessary, yet, but I have stereo AUX-out with Volume control, which is all I’m looking for.

Without regurgitating everything I tried various things in this thread IQaudiO Pi Digi+ helped.

In config.tx hashed out dtpram

#dtparam=audio=on

Edited the dacs.json file adding this line

{“id”:“iqaudio-codeczero”,“name”:“IQaudIO Pi-Codec Zero”,“overlay”:“iqaudio-codec”,“alsanum”:“2”,“alsacard”:“IQaudIOCODEC”,“mixer”:“Digital”,“modules”:"",“script”:“iqamp-unmute.sh”,“needsreboot”:“yes”},

Added a new codec state file in the boot directory. I created codeczero.state and pasted in Github playback only files

I then ran this as appropriate

sudo alsactl restore -f filename.state

which loaded the file. Which will be temporary at this point.

Testing Volumio, I still got the ALSA No such device “Volumio” error. However, If I turned off the I2S DAC, I then got this…

Codec Zero

Which is not quite right, but it works!

Now to reboot, and see what breaks. I’m not convinced by the dacs.json file either as its come up with IQaudioCODEC not IQaudIO Pi-Codec Zero which I was expecting…

I also need a suitable enclosure, as the one I bought is almost, but not quite big enough. Typical!

-------UPDATE-------

I think the correct Dacs.json file above will fix it. Im not convinced the state file made difference. I need to do another fresh install to try at some point.

As a quick update.

Factory Reset & Upgraded to 3.378

The dacs.json file needed to be edited, which gets ALSA to be happy, however it does need the STATE file to be modified as above to get it to play audio out of the right port. In my case Stereo Aux out

Also running a GPIO Pins plugin to enable Play/Pause on Pin 27 which is the push button on the side of the Codec Zero.

Volumio 3378

I Must have made a typo in the dacs.jason last time, as the DAC now appears correctly within the playback options.

Only gripe, was when factory resetting, I lost all my music, which I wasn’t expecting.

Did I upload it where I shouldn’t have?

Ok Its not stylish, but its working :slight_smile: