IQ Audio DAC Pro, no sound (the usual "failed to open ALSA hw 2.0")

Hello.
Can’t find this specific issue in previous threads, so here I am (and yes I have rebooted several times to no avail…)

Have a Rpi3b+, powered by official Pi4 supply, new SD card, installed the IQ Audio card with a Waveshare 3.5" Lcd on top.
Installation of the screen went well with no real issues, image and touch working well. But there’s no sound, the audio hardware (cable, amp) is proof since it works with anyhting else and was working with the previous Pirate Audio Line-out.

I have followed the official instructions (https://datasheets.raspberrypi.com/iqaudio/iqaudio-product-brief.pdf) to select “IQ Audio Digiamp+” as l2s, but have the “failed to open ALSA hw 2.0” message, which seems to be a wrong/unsupported DAC?
I have tried to select different DAC types resulting in the same error message. If I select “HifiBerry DAC+” there’s no error messages but still no sound.

Has anyone had the same issue? I am a bit puzzled here.

Thanks!

Forgot to add the aply -l log:

volumio@volumiotouch2:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/3
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2

something’s not right here, the IQ Audio card is not listed…

Also the /boot/config.txt:

volumio@volumiotouch2:~$ cat /boot/config.txt
initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
gpio=0-9=a2
gpio=12-17=a2
gpio=20-25=a2
dtoverlay=dpi18
enable_dpi_lcd=1
display_default_lcd=1
extra_transpose_buffer=2
dpi_group=2
dpi_mode=87
dpi_output_format=0x6f006
hdmi_timings=640 0 20 10 10 480 0 10 5 5 0 0 0 60 0 60000000 1
dtoverlay=waveshare-35dpi-3b-4b
dtoverlay=waveshare-35dpi-3b
dtoverlay=waveshare-35dpi-4b
include userconfig.txt

Volumio i2s setting below: do not alter

dtoverlay=iqaudio-dacplus,unmute_amp

and

volumio@volumiotouch2:~$ cat /boot/cmdline.txt
splash quiet plymouth.ignore-serial-consoles dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0xF dwc_otg.nak_holdoff=1 console=serial0,115200 kgdboc=serial0,115200 console=tty1 imgpart=/dev/mmcblk0p2 imgfile=/volumio_current.sqsh elevator=noop rootwait bootdelay=5 logo.nologo vt.global_cursor_default=0 loglevel=0 snd-bcm2835.enable_compat_alsa=1 snd_bcm2835.enable_headphones=1