iOS track time display issue

When using Safari (iOS - iPhone 5s) the track progress indicator seems to move, but the time doesn’t change. As I change between sections (browse, playback, playlists, etc), it updates but then still does not change as the song plays.

The playback counter seems to work fine when viewed in other browsers (namely, chrome) on my laptop.

volumio 1.1 beta on a raspberry pi, output via the built-in 3.5mm audio jack. mp3 files being played via mounted smb share.

If any more info is needed, let me know.

I have the same problem, and it happens in OS X Safari 7.0.1 too.

I also encountered this problem. It seems to be a bug in jquery.countdown.js 1.6.2, the version that is used for Volumio.
You can solve this by replacing jquery.countdown.js 1.6.2 in /var/www/js with version 1.6.3 found here:
Make sure to clear safari’s cache!

confirm this still happens for iOS 8.3 on volumio 1.55 - progress ring progresses but counter doesn’t advance
replaced the file using wget and all works now - thanks for the fix!

is there anything that does not work now?

[code]root@volumio:/var/www/js# ls -la jquery.countdown.js
-rw-r–r-- 1 root root 32807 Feb 7 17:42 jquery.countdown.js
root@volumio:/var/www/js# mv jquery.countdown.js backup/
root@volumio:/var/www/js# wget
–2015-05-23 13:34:36--
Resolving (… 2001:470:1f15:1a45::2,
Connecting to (|2001:470:1f15:1a45::2|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 33055 (32K) [application/javascript]
Saving to: `jquery.countdown.js’

100%[==========================================================>] 33,055 --.-K/s in 0.04s

2015-05-23 13:34:36 (741 KB/s) - `jquery.countdown.js’ saved [33055/33055]

root@volumio:/var/www/js# ls -la jquery.countdown.js -rw-r–r-- 1 root root 33055 Aug 3 2013 jquery.countdown.js



Thanks, I’ve updated the jQuery countdown package in the Volumio repo. :slight_smile:

Same issue on Firefox 38 for Windows/Ubuntu.
Updating jquery.countdown.js solved the problem.