Invisible USB hard-drive

Today I tried to install volumio (version 2.915 of September 30th) on an Intel NUC. I succeeded eventually but for one crucial thing. My intention was to use a Seagate external USB drive as my music source. That drive has an ext4 filesystem on it and is mounted at /media/seagate and the music is in a directory called Music. The permissions are as they should be; the drive can be seen by lsusb; I can browse the music, if I log in via ssh, under /media/seagate , under /mnt/USB/seagate and also in /var/lib/mpd/music/USB/seagate.
But it’s inaccessible in the volumio user interface and does not show up under Sources to be scanned. The documentation suggests that USB drives will always be detected automatically and their contents added to the Music Library; as far as I can see there is no way to add such a drive manually, as one does with network shares. But that leaves me stuck (Obviously I’ve tried restarting).
If there were any advice available here, I would be very grateful for it.


Answering myself to complete the record. The problem here seems to have been that the audio files were somehow corrupted, or at least changed in some way, in the course of being copied. And that caused the creation of volumio’s internal data-base to fail. I don’t understand in what way the files were changed/corrupted in transit but once I recopied them carefully the problem disappeared, the music library was detected automatically, and the tracks were indexed with impressive speed. So all is good, apart from the lack (on my part) of any good understanding of what the underlying issue was.

Glad it is solved.
If I can suggest, if you use ext4, copy files in a way they can be accessed by the volumio user

Thank you very much, Michelangelo. I’m not sure I undertand, though – do you mean accessible in the sense of ownership and permissions? In the case in point, the files are owned by the volumio user in the volumio group and the permissions are set at -rw-r–r-- . Directories are readable and executable by everyone and also owned by volumio.volumio. The volumio user also has write permission in the directories. But perhaps you meant `can be accessed by the volumio user’ in some different sense?
In any case, I appreciate your interest and concern, along with all of your other work.