INTERNAL and USB sources not visible

Hi, I have a problem since the last update to Volumio version 2.703.
I’m running Volumio on Rpi2 with HifiBerry.

I’ve been using INTERNAL and USB mount points for local music as well as some sshfs mounted sources.
The problem is, that since the last upgrade neither of them is visible in the Library. The library is effectively empty, while i can see everything on Volumio when logged in via ssh.
I tried remounting to INTERNAL, doing Update and Rescan, nothing helps - “Sources > My Music” is empty.

Please help me with some advice on how can i solve this…

Thank you,


Hi Peter,
can you check the permissions under which you mounted your files? They must be accessible from “audio” group

Hi Michelangelo!

I’ve checked the permissions on /mnt
lrwxrwxrwx 1 root root 14 Feb 26 22:21 INTERNAL -> /data/INTERNAL
drwxrwxrwx 1 root root 4096 Feb 25 10:49 NAS
drwxrwxrwx 2 root root 3 Feb 26 22:21 UPNP
lrwxrwxrwx 1 root root 6 Feb 26 22:21 USB -> /media

/data/INTERNAL is currently empty, I’ve tried mounting there with no success.
I’ve also tried copying an mp3 file there that had permissions -rw-r–r-- 1 volumio volumio with no success, the file never showed up in My Music.

On /mnt/NAS
drwxrwxrwx 34 nobody 65533 34 Mar 22 2018 Freenas
There are a few subdirectories there with music. The share is visible as mounted in Settings, but nothing is visible in My Music.

On /media/Music
drwxr-xr-x 1 peter peter 4096 Nov 5 2014 pop
drwxr-xr-x 1 peter peter 4096 Nov 5 2014 jazz
drwxr-xr-x 1 peter peter 4096 Jun 16 2014 rock

Music is a sshfs mount point that is mounted with user peter and this user is a member of audio group.
I’ve enabled the user_allow_other option in fuse.conf.

My whole Library is currently empty, including my custom added Webradio stations.

Since you’re mounting “manually” it’s really hard to suggest what might be the solution.
Can you just use the UI only to mount your music? This way you’ll have 100% chances of success…

The Freenas NFS was actually mounted via gui, but nothing is visible.
For sshfs there is no option to do it.

I’ve updated Volumio to the latest available version last night, there was no change regarding my problem.

I have the same problem. I use a Gigabyte Brix.
The internal hd doesn’t show nor usb attached drives.
Sources -> my music is empty, no music…

An update on the subject…
Today I clicked the Update button in Sources -> My Music and it suddenly started to add Artists, Albums and Tracks… It’s still running and adding them.

The funny thing is that I did not change anything from the last post and did not update System version in the meantime (it says I have the latest version).
I have no explanation for this at the moment. I did remount the directories with a user that belongs to group “audio” as Michelangelo suggested a few days ago. Maybe there’s a delay till system rescans these drives? Manually pressing Update or Rescan button did not help when i tried it a few days ago.

What IP command I need set in browser for playing misic from USB source and radio source ?

One of the older versions had a big where it would not start adding newly added media content automatically.

Latest version fixes it.

Sent from my POCOPHONE F1 using Tapatalk