Integrated SPDIF out problem on Cubox-i 4P

Dears I have recently installed this image volumio-2.857-2020-12-16-cuboxi.img on my Cubox and after some tests I can’t have output signal from SPDIF.

I have tried to make some debug on it and the kernel seem recognise the correct driver but alsa appear misconfigured.

Here an image of alsamixer after a fresh install:

To get more information about this issue I have executed alsa-info.sh, at this link you can find the result:
http://alsa-project.org/db/?f=b139f403ee5ffd7041bce4eb92438a0c289450ba

Please someone can give me some help to solve the problem?
Thanks in advance for the support!
G.

SPDIF does not have mixers, so the message is correct.

I have tried to change the DAC but with no results.

The signal appear to be transmitted from Cubox to DAC but I still can’t heard nothing, the red point is visible in the optic cable.

During my tests I have observed a strange thing in the web GUI:

Screenshot 2021-04-22 at 09.04.41

Seems that the audio outputs are disabled. Maybe it could be the real problem?

Yesterday I have tried the HDMI port and the audio work without any problem.

I’m still thinking that the problem is the DAC.

Sorry @gkkpch may I know what model of DAC are you using with Cubox i4? Thanks in advance!

I do not have a Cubox-i4, but the cubox-i2ex. For testing new images it is mostly connected to a small Chinese SMSL SD-793II headphone amp.It has both coax and optical (toslink) inputs.
But the Cubox-i2ex also works well here with a Pro-ject Pre Box S2 Digital.
Have you considered using a USB DAC?

I’m considering the TOPPING D10s DAC do you have any news about it? It will be compatible with Volumio?
TOPPING D10s seems to me the best DAC considering quality and price.

D10S should work just fine with Cubox-i

Thanks worked like a charm! :smiley: