Installing the Touch Display plugin

I’m not sure but the packages raspberrypi-kernel and raspberrypi-bootloader are required by libraspberrypi0 which is a dependency of chromium package.

If you pin and hold both packages, will libraspberrypi0 be installed? In my tries it refused to install in case of missing dependencies.
So i could not install chromium.

No, with the held packages, libraspberrypi0 won’t be installed either, but install procedure will not complain about it either (it’s a firmware update you don’t want anyway, as it would break distribution).
Then the only dependencies problems reported are those described in post #p29708, which I resolved as explained in that post.
From there, plugin install does not fail and Pi boots normally.

Just the plugin does not fully work yet in my case due to X failing to start: maybe it’s a HDMI-specific issue as I do not use DSI port-based screen.
Maybe it’s fine for 7″ Touchscreen Monitor which this plugin is initially intended for?
So not completely resolved yet for me, but should be very close now…
Any idea for the X thing?

The issue may be due to recent packages: there are few articles about that.
So tried to work backwards and find older dependencies which may work (would be interesting to check with X library versions on working 2.041).
The only thing I could get to was to sequentiallysudo apt-get install xserver-xorg-core=2:1.16.4-1 sudo apt-get install xserver-xorg-input-evdev=1:2.9.0-2 sudo apt-get install xserver-xorg=1:7.7+7+b1 sudo apt-get install xorg=1:7.7+7+b1and then mark them hold, before installing the plugin (which installed fine). However x session did not work either.
I leave it here in case someone has more success in finding-out this last bit.

I’ve just updated the plugin zip. Now the installation should work and your volumio will survive…
Please, for the braves, let me know how it goes :wink:

thanks for your job its working !! from a clean start its ok.
note : the screensaver settings are not ok on the file
the “dpms” parameter is missing, i’ve replace “xset 0 0 120” by “xset dpms 0 0 120”

I just installed Volumio on a Raspberry Pi Zero W with Waveshare 5" display. The plugin works, but I’m missing the possibility to change resolution etc., I needed to do this manually.


Thank you very much! The plugin works fine!

  • Volumio Version: 2.118
  • Raspberry Pi 3
  • 7 Zoll Raspberry Display

Unfortunately the German language pack does not work.

I noticed something else …
The screensaver is not disabled. After a few minutes I have a black display.

After flashing my sd card several times, I tried to use volumio 2.118 for installing the touch ui plugin (RPi3/RPi Touch screen 7").

But, it always stop at 70% and is asking for a keyboard layout from 1-21.

Is there a easy work around for this?
Dpkg --configure -a does not show any way around.

sudo apt-get install keyboard-configuration before installing the plugin

Okay, now the script is executing “Unpacking libauthen-sasl-perl (2.1600-1) …” since 70 minutes now after flashing a totally new 2.118 image.

I successfully installed the Touch Display plugin on a clean install of 2.118!

Thanks to all for fixing this.

Yeah, thanks all… my touch plugin is installed, too…

The display is shutting off after a long period. Did not find a setting to automatically switch it off after 3 minutes or similiar.

Finally I also got it installed from a plain image :slight_smile:
With the updated plugin and installing keyboard-configuration before plugin, everything works.

The only problem is the lack of speed, as the whole boot up process takes way too long for me.

try this ?? : the screensaver settings are not ok on the file
the “dpms” parameter is missing, i’ve replace “xset 0 0 120” by “xset dpms 0 0 120”

Where to Download the newest Plugin or can i install it from volumio Plugins?

My RPi3 with Volumio 2.129 has no internet connection. Where can I download the touchscreen plugin manually?

Where is the file located?


Found it, and I made the edit listed above

#!/bin/bash xset +dpms xset s blank xset dpms 0 0 120 openbox-session & while true; do /usr/bin/chromium-browser \ --no-touch-pinch \ --kiosk \ --no-first-run \ --disable-3d-apis \ --disable-breakpad \ --disable-crash-reporter \ --disable-infobars \ --disable-session-crashed-bubble \ --disable-translate \ --user-data-dir='/data/volumiokiosk' --no-sandbox http://localhost:3000 done

And still my screen goes blank after several minutes (haven’t timed it). I can go to the plugins section of the UI and set to Inactive and toggle back to Active, and the screen returns - and again goes blank after a few minutes.