Install Volumio to Internal Hard Drive

Austria isn’ t that far away. :wink:

Is there any routine for touch-calibration? Or where can i find the file with the values for the touch?

Thanks, Thomas

Hoi Thomas,
you will have to google yourself for that if the following does not work.
From what I read the calibration data is stored in /etc/penmount.dat
Perhaps you can calibrate with ubuntu desktop, secure the file and use it on your volumio setup.
Worth a try…

– Gé –

Can anyone point me in the right direction? I’m trying to install on a HP thin client PC. It only had a 2GB flash drive, and I couldn’t boot from a USB drive as when I plug in my external USB HDD full of music, the BIOS gets confused tries to boot from that, so I bought an IDE-CF adaptor, and fitted a 8GB CF disk.

I booted with knoppix, and used dd to write the image as per the instructions at the start of this thread. The mechine boots, brings the wireless up, and I can access the web interface, but I have a problem after rebooting: it will hang- usually just at the syslinux message, but sometimes it will come up with the Volumio legacy boot message and then hang. I’ve reflashed twice and it’s the same each time. I’ve got a bit of linux knowledge and can boot the PC back into Knoppix if needed: what should I try?

The box has a Via CPU, 1GB of RAM (some used for graphics), and has a legacy BIOS. I’ve been looking for a use for it for a while :slight_smile:


Hi Chris, I´am not sure if it can help you … but have you tried to configure the BIOS to boot in UEFI? I have experienced this as solution to boot in a virtual machine on an ESXi host.


Thanks for the response. I didi think that, what with there being an EFI filesystem, but sadly the hardware doesn’t have UEFI, just a legacy boot. If I get some time over the weekend I’ll dig through the syslinux docs, because all the filesystems are there, it just gets stuck on booting. I think I might also run a copy of standard Debian onto the box just to give the CF card a quick test, though as it boots once I guess it’s probably OK.

In case it’s useful for anyone, I solved my problem, I think. I installed to an old magnetic HDD and that was fine, so wiped the CF with dd and put it back: I then couldn’t get knoppix to boot. Remove the CF and it was fine. Put the CF back, knoppix boots.

This is a, HP T5570 with a no-name CF adaptor, and a Kingston CF card.

I think the BIOS HDD detection is buggy. I updated the BIOS with no change, and each time, the failed boot- either knoppix, volumio, or the Debian install I tried , took me back to when I first played with Linux in about 1998 and LILO: boot failures were almost always HDD geometry problems. I’ve found this to work:

  1. Put Volumio image on USB stick.
  2. Install the CF. Enter the BIOS, view the HDD detection, set boot order to CD only.
  3. Boot knoppix from DVD with “knoppix 2” for text mode only.
  4. Mount the USB and write the image as described at the start of this thread.
  5. sync, sync, init 0
  6. Reboot, enter BIOS setup, view disk config again, set boot to CF card only.
  7. Exit BIOS. Allow Volumio to boot and set up the disk.
  8. Shut Volumio down, reboot, enter BIOS, view disk config yet again. Ensure boot is the CF only.
    9, Exit BIOS, allow to boot normally.

I’m guessing viewing the disk detection updates something.

Updating the BIOS took me back too: I had to use a DOS boot floppy…

Hi Chris,
Thanks for sharing this.
We have a new topic in Section “Compatibility”. Could you perhaps add your x86 info and your experience from the above post?
– Gé –

Hi all,

I am a newbie here and have limited linux knowledge. I have been trying to install Volumio 2 on the flash memory of a Wintel Pro “TV Box”. The Wintel runs Windows 10 Home just fine but when I copy the x86 image to it using the instructions in this post (sudo dd if=fullnameofthevolumioimage of=/dev/sdY bs=4M, replacing sdY with the device associated with the internal flash memory), it copies correctly, although slowly, and when complete I have the three partitions. But when I boot the device, it dies during the boot process indicating it can’t find the UUID of the image. I assume this is because it is looking for /dev/sda, which it cant find since the flash has a different device name.

Is it possible to use another image that is meant to be installed on flash memory? Any help would be greatly appreciated.

Here are the specs on the Wintel Pro “TV Box”:

W8 Pro mini PC
USB 3.0
RTL8723 Wireless 802.11 b/g/n
100M Ethernet
Bluetooth 4.0
HDMI 1.4b
Intel Atom x5-Z8300 Cherry Trail

I have installed Volumio 2 on an old Dell laptop and it is working correctly, but would really like to get it installed on this mini-pc.

Thanks for any help you can provide.


PS I forgot to mention that I can also boot Volumio directly from a USB drive on the Wintel box, but I have to enter the bios to select the USB drive each time it boots. (The Wintel bios does not have an option to change the default boot order… the main reason I want to boot from the internal flash memory). Everything seems to work correctly when I boot from the USB drive, other than no audio from the HDMI connection. My receiver does have HDMI in, so I would like to use HDMI rather than a USB DAC but I have decided to wait until I can see if I can boot from flash before I spend time on the HDMI audio. Thanks again. Carl

Hi Carl,
before digging into this with the old kernel version 3.18.25, could you try this experimental image and check if it behaves better?
When it fails, you’ll be in initramfs, could you issue blkid and report the result?
Camera screenshot is ok too as long as it covers all.
– Gé –

Is there any possibility to install volumio to an external harddisk of a Raspberry Pi3? Would be very nice if someone with more advanced knowledge can give me a hint. Thank you.

Could you please not spam the x86 thread with off-topic questions.
Hardly anyone will expect RPI questions here, so you benefit more from your own thread.

The thread title is “Install Volumio on internal HD”. It’s very unfriendly to name my question about installing to external HD spamming. I think a forum is for sharing knowledge. I am starting using Volumio and you and other people who are more advanced perhaps can give some help. I need to make the Usb Hd bootable, which is also mentioned in this thread with a usb stick.
Theres a thread about X86 started from you here mentioned in the title
Maybe you think first about your words before writing any harsh words.

noted, sorry.

@gkkpch, can you add x86 in this thread title to avoid possible confusions then?

@Hf4d2skwk8, for an interim RPi solution (until official support), you may look into that.

Thanks - just used this very on my eee pc and it works VERY well!
One question - I have a Quad DAC that I’m trying to feed using the eee PC - however I think a driver is needed.
How can I install a driver when the system is booting from a flash drive?

This is an old thread with links to Volumio dev versions which are unsupported and obsolete, especially on the above mentioned file server.
They were removed as of today.

Please use a newer version from the dev thread until we publish the beta based on Debian stretch (finishing the last bits, coming soon)…

I login with volumio/ volumio It asks for a password ?

Not really sure what you are trying to do. Is this really on an x86 device?
Do you only see the volumio login prompt, no UI?
We do not want to start guessing what your problem might be without having any hardware information.
Could you please supply more details?

I get errors when I mount, mountpoint bussy and I do not know what the imagename is to put after if=

Just posting a half sentence in the middle of an old thread is not helping me much, I hope you can understand how difficult is to guess what problem you have and where things went wrong.
Please tell us what exactly you did, from the beginning, then we may be able to help.
Could you put all your issues in one place, so I can take care of it?