Install peppy meter in volumio

When you use a screen of the size of meters, the whole screen is peppymeter. Now the the plugin is in early state of dev. I can add option to select fbdev or input or whatever needed. The main interest is the way it pipes audio from all sources in volumio.

1 Like

Nevertheless it is great that we have the posibility to have this meter as a plugin and over time it will be improved like balbuze said. I like that our ideas are taken into account. I never thought that when I have started this thread to have it is a plugin. As soon as ai receive my extender cable I will install it under beta volumio version. Now it is to hard to extract the SD card from my streamer.

1 Like

I really appreciate your hard work.

I have been looking around for some info to use Volumio on a dual screen rpi 4 setup (rpi 4 has 2 hdmi ports).
But I couldn’t find anything about it.
I was thinking of using that setup. One (touch)screen for the Volumio-UI, the other screen (ie Waveshare 1200x400) for the wide-Peppymeter.
Maybe this brings you to an idea.

1 Like

What is different from volumio 3 beta version from v 3.015 from ashtephy? I know that volumio beta 3 does not support plugins…

Plenty of improvement… And the new alsa pipeline is activated by default
Beta does not provide plugin because the target is to debug Volumio… But if you don’t complain in beta thread, you can still install plugins “by hand” :wink:

13 posts were split to a new topic: [NOT RECOMENDED!] Plugin adventures on Buster betas

Hi Lintbf & Balbuze,

Could you direct me to the used volumio 3 beta version by you and the Touch Display plugin, please.

@Lintbf can you explain how you start pepymeter from the commandline with openvt?
I use this: “sudo openvt -s python3” , but I get peppy errors (I have openvt installed, that’s ok).

Does anyone have an idea how to move the peppyscreen out of the left upper corner?

Hello, just change the screen size from plugin settings.
I have used beta version then înstall touch plugin and peppymeter from balbuze modular folder on github. In touch display plugin thread you will find the steps to install touch plugin from gvolt. It is the last 2 posts.
I will not use the openvt command.
With large settings

Do I read (between the lines) that the peppy-screen still “overlays” the volumio-screen?
I found the Touch display plugin (I think).
Where can I find the latest Volumio-3 builds?

Hello balbuze,
The peppy meter plugin keeps the display awake? I have configured the touch plugin display to enter in shutoff state but nothing, but if I switch off the peppy for local display off then the dsi display enter on sleep mode.

possible… As I said, it is just front end for peppymeter. Need probably some tweaks :upside_down_face:

I know I just wanted to tell you this behavior.
Also it will be great to have a button on the screen in the wright bottom corner to close the peppy window. And one button on volumio UI to enable this peppy meter.
Regarding the spotify când I copy with winscp all files from github and install it then?


I had a fine working situation of Volumio-3.051 (updated to 3.054) with V3-touchscreen and Peppymeter on Rpi-3b.
Now trying to install it again (V3.051). With Peppymeter installed and activated, I get an Alsa-error as soon as I want to start music. It worked before installing Peppy.
I did it a few times, with te same result…

Any ideas?

Schermafbeelding 2021-03-17 om 16.18.06

I stil have an earlier download. See if that works. I see that has changed.

I made a change to avoid to compile peppyalsa a install time. So a precompiled lib is provided. But maybe something is wrong in can you check if exist in /use/local/lib ? Thanks

As far as I have seen only

What is the size?

ls -axl

It can’t work like that…
Try from /user/local/lib

sudo ln -s -f

Sorry :blush:
I was already installing again…, can’t tell

The older one works fine…

Must be, unless other things have changed as well.

I had the same problem with
route_policy “duplicate” and find out, the problem is the missing dummy device. This device needs the kernel modul snd-dummy. It’s not load at startup in version 3.066.
Please add the follow line at last line in:



Then the route for PeppyMeter with dummy device as output is working again.

1 Like