Install peppy meter in volumio

yes!

I had a fine working situation of Volumio-3.051 (updated to 3.054) with V3-touchscreen and Peppymeter on Rpi-3b.
Now trying to install it again (V3.051). With Peppymeter installed and activated, I get an Alsa-error as soon as I want to start music. It worked before installing Peppy.
I did it a few times, with te same result…

Any ideas?

Schermafbeelding 2021-03-17 om 16.18.06

I stil have an earlier download. See if that works. I see that install.sh has changed.

I made a change to avoid to compile peppyalsa a install time. So a precompiled lib is provided. But maybe something is wrong in install.sh. can you check if libpeppyalsa.so.0.0.0 libpeppyalsa.so exist in /use/local/lib ? Thanks

As far as I have seen only libpeppyalsa.so.0.0.0

What is the size?

ls -axl

It can’t work like that…
Try from /user/local/lib

sudo ln -s -f libpeppyalsa.so.0.0.0 libpeppyalsa.so

Sorry :blush:
I was already installing again…, can’t tell

The older one works fine…

Must be install.sh, unless other things have changed as well.

Hi,
I had the same problem with
route_policy “duplicate” and find out, the problem is the missing dummy device. This device needs the kernel modul snd-dummy. It’s not load at startup in version 3.066.
Please add the follow line at last line in:

/etc/modules-load.d/modules.conf

snd-dummy

Then the route for PeppyMeter with dummy device as output is working again.

1 Like

Just took the time to install this wonderfull plugin, nice!

As the PI4 is connected to an 4K TV through HDMI, the PeppyMeter is now quite small and in the left upper corner. Was there a way that I could manually adjust the location and size manually in the config files?

Very excited about this plugin!

The peppy meter was working yesterday. Today there is a new update for volumio Volumio-3.173-2021-12-08-pi.img and the peppy meter has stopped working.

turn it off and on again. (the plugin I mean)

Did not help. I’ve done this several times.

1 Like

the I woud do a uninstall and reinstall. Had simular issues with a combi of plugins and un and re-install solved the issue

It boots up, but the level meter indicators do not work.

@2aCD

Hi Falk,
Can you look at this on?

@Marek_Grzeszczak
Have you installed other plugins, which?

I did it just like in the movie. Volumio with PeppyMeter PlugIn Installation Guide - YouTube

Please remove/undo everything and just use the plugin. Be aware that this plugin is not yet released for V3!!

OK, I’m resigning. It got too hard for me. Will try to go back to the volumio 2 version.

I did everything as described. I copied the folder. Unfortunately, the markers are still stationary.

then request assistance in this topic: