Install of volumio 3 always ends up with "can't access tty"


Trying to install Volumio 3 but always fail with “sh: can’t access tty: job control turned off”. I get the same with 3.194 and 3.198. I’ve tested version 2.917 but then get error “start4.elf is not compatible”

Video of boot can be found at IMG_4908.MOV - Google Drive

Raspberry Pi OS (220128) installs without any issues.

Hardware Raspberry Pi4 v1.4
MicroSD SanDisk Ultra
Goobay 59089 USB 3.0 Type A to SD Micro SD reader

/dev/disk2 (external, physical):
0: FDisk_partition_scheme *31.9 GB disk2
1: Windows_FAT_32 boot 96.0 MB disk2s1
2: Linux 2.7 GB disk2s2
3: Linux 146.8 MB disk2s3
(free space) 29.0 GB -

splash plymouth.ignore-serial-consoles dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0xF dwc_otg.nak_holdoff=1 quiet console=serial0,115200 console=tty1 imgpart=/dev/mmcblk0p2 imgfile=/volumio_current.sqsh rootwait bootdelay=5 elevator=noop logo.nologo vt.global_cursor_default=0 net.ifnames=0 snd-bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 loglevel=0

initramfs volumio.initrd

include userconfig.txt

Any ideas?


Hi @Socket.
Here are two ideas:

  • use Raspberry Pi Imager to flash the Volumio image
  • try with another SD card, if you have one available

Thanks for the input,

  • I’ve made images with both balenaEtcher and Raspberry Pi imager but always the same.
  • Also tested with a second SD memory card but always the same.

Have you tried with disconnecting everything from USB, just the pi and the SD?

Only thing connected to it is the Goobay (59089) USB SD card reader (tried with standard and micro SD card) and the HDMI cable.

Volumio will only boot from SD in the SD-card slot. Not from any USB device. Hence the USB errors.

But of course, how on earth did I manage to miss that :sleeping:

Thanks for rescuing me from going mad :rofl: works like a charm :+1:

HI anyone please help me. I also have the same problem but now with a raspberry pi. It is for my laptop. I had it installed on my laptops twice and it worked flawlessly. I tried to install it on another laptop but when I tried to boot it from the usb flashdisk, it won’t boot and I got the message " sh: can’t access tty: job control turned off.

What might be the problem? With the first two laptops with the same usb flash disk, it worked.