Install npm module - problem

This is also good to know, thanks for clarifying. On the other hand, I can also imagine a central repo for all plugins could be considered beneficial. Oh well, there’s plenty of stuff that’s “nice to have”, I’ll focus on getting stuff up-and-running on Buster first :wink:

Hi @Saiyato,

I am using some of your plugins on Buster since long time, updating some of the node modules.

Here the script I use for installing them

sudo apt -y install build-essential
cd ~
wget http://plugins.volumio.org/plugins/volumio/armhf/system_controller/gpio-buttons/gpio-buttons.zip
mkdir ./gpio-buttons
miniunzip gpio-buttons.zip -d ./gpio-buttons
cd gpio-buttons
volumio plugin install
## when installation is finalized, press CTRL+C ##
cd /data/plugins/system_controller/gpio-buttons/
npm install --save onoff@6.0.0
sudo apt -y install build-essential
cd ~
wget http://plugins.volumio.org/plugins/volumio/armhf/system_controller/gpio_control/gpio_control.zip
mkdir ./gpio_control
miniunzip gpio_control.zip -d ./gpio_control
cd gpio_control
volumio plugin install
## when installation is finalized, press CTRL+C ##
cd /data/plugins/system_controller/gpio_control/
npm install --save onoff@6.0.0
npm install --save sleep@6.2.0
sudo apt -y install build-essential
cd ~
wget http://plugins.volumio.org/plugins/volumio/armhf/system_controller/gpio_radio_buttons/gpio_radio_buttons.zip
mkdir ./gpio_radio_buttons
miniunzip gpio_radio_buttons.zip -d ./gpio_radio_buttons
cd gpio_radio_buttons
volumio plugin install
## when installation is finalized, press CTRL+C ##
cd /data/plugins/system_controller/gpio_radio_buttons/
npm install --save onoff@6.0.0
1 Like

Hi @Darmur

Can I trouble you for some help.
I am trying to get Saiyato’s rotary encoder working.

Ive followed your method of getting the GPIO plugin to work and that does work OK. But the rotary encoder, goes through the same motions then the plugin fails to start and also upon reboot something stops volumio webpage from loading at all.

this is how I tried

sudo apt-get update

sudo apt-get -y install build-essential

cd ~

wget http://plugins.volumio.org/plugins/volumio/armhf/user_interface/rotaryencoder/rotaryencoder.zip

mkdir ./rotary

miniunzip rotaryencoder.zip -d ./rotary

cd rotary

volumio plugin install

cd /data/plugins/user_interface/rotaryencoder

npm install --save onoff@6.0.0

any ideas

Thanks

1 Like

I also had problems with that plugin, I never managed to get it working

Anyhow, with the alternative plugin I have no problems, it works fine on Buster

1 Like

Thanks for the reply,

I Have already, tried that plugin. Which as you say can be installed OK and also loads up fine.
Although I just cannot get it working correctly, It seems very flaky. the push button if set to play/pause when clicked plays sometimes but 90% of the time instanly goes straight back to pause. The rotary part just doesnt work at all in V3. Even in volumio 2 the rotary was very erratic.

Yet Saiyato’s rotary plugin works perfectly for me in V2.

1 Like

Hi
@Darmur

Did you do anything other than you wrote above to get Rotary Encoder II working in V3

I just spent some time getting it up and running with Volumio 2, changed a few component values to fine tune the hardware debouncing. Rotary encoder II now works spot on on volumio 2.

But still nothing with the rotary in V3, button works fine though to play and pause. seems strange.

Thanks for your time

1 Like

try to reboot after setting up the plugin

Hi

ive tried that, to no avail…

in the live log every time i press save for the encoder settings, at the bottom is always Process '/usr/sbin/th-cmd --socket /var/run/thd.socket --passfd --udev' failed with exit code 1.

so im guessing this is the issue, which is starting to get beyond me.

1 Like

I don’t know what to say, the plugin works for me on Volumio3 (Buster), besides a small issue when two encoders at the same time

Ive tried a fresh install, and still the same.

The only difference I can think, what version of Volumio 3.*** are you using. Maybe something broke along the way. I’m trying the latest 3.152

I am using 3.156

is that a typo, I dont see a 3.156 available.

edit : Enabled test mode and there it is

edit 2 : Made no difference.

Oh well, time to call it a day. Ive had enough

Thanks for your input :+1:

1 Like

@Darmur
@M1ck
Hello . get the following error when installing! And the gpio_control plugin can be seen in Volumio. but does not work

Volumio_telnet.txt (156.5 KB)

I only tried the one you ask about, gpio-buttons plugin and that installed and worked fine for me.

1 Like

are you also on version 3.163?

1 Like

I have just flashed a fresh 3.163, set it all up…etc
Then through command line installed GPIO buttons, also updating node modules
then activated in volumio 3, set it up to use power button to shutdown which also works as it should. Click and instant shut down…soo much better than V2 which sometimes took a week to shut down.

SSH window of installing GPIO- buttons

                       ___
                      /\_ \                        __
         __  __    ___\//\ \    __  __    ___ ___ /\_\    ___
        /\ \/\ \  / __`\\ \ \  /\ \/\ \ /' __` __`\/\ \  / __`\
        \ \ \_/ |/\ \L\ \\_\ \_\ \ \_\ \/\ \/\ \/\ \ \ \/\ \L\ \
         \ \___/ \ \____//\____\\ \____/\ \_\ \_\ \_\ \_\ \____/
          \/__/   \/___/ \/____/ \/___/  \/_/\/_/\/_/\/_/\/___/

             Free Audiophile Linux Music Player - Version 3.0

          © 2015-2021 Michelangelo Guarise - Volumio Team - Volumio.org

Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Welcome to Volumio for Raspberry Pi (5.4.83-v7l+ armv7l)
volumio@volumio:~$ sudo apt-get update
Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Get:3 https://deb.nodesource.com/node_14.x buster InRelease [4584 B]
Get:4 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0                                                                              MB]
Get:5 http://archive.raspberrypi.org/debian buster/main armhf Packages [393 kB]
Get:6 https://deb.nodesource.com/node_14.x buster/main armhf Packages [779 B]
Get:7 http://raspbian.raspberrypi.org/raspbian buster/contrib armhf Packages [58                                                                             .8 kB]
Get:8 http://raspbian.raspberrypi.org/raspbian buster/non-free armhf Packages [1                                                                             04 kB]
Get:9 http://raspbian.raspberrypi.org/raspbian buster/rpi armhf Packages [1360 B                                                                             ]
Fetched 13.6 MB in 8s (1719 kB/s)
Reading package lists... Done
volumio@volumio:~$ sudo apt -y install build-essential

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for volumio:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  bzip2 cpp cpp-8 dpkg-dev fakeroot g++ g++-8 gcc gcc-8 libalgorithm-diff-perl
  libalgorithm-diff-xs-perl libalgorithm-merge-perl libasan5 libcc1-0
  libfakeroot libgcc-8-dev libisl19 libmpc3 libmpfr6 libstdc++-8-dev libubsan1
  make patch
Suggested packages:
  bzip2-doc cpp-doc gcc-8-locales debian-keyring gcc-8-doc libstdc++6-8-dbg
  gcc-multilib autoconf automake libtool flex bison gdb gcc-doc libgcc1-dbg
  libgomp1-dbg libitm1-dbg libatomic1-dbg libasan5-dbg liblsan0-dbg
  libtsan0-dbg libubsan1-dbg libmpx2-dbg libquadmath0-dbg libstdc++-8-doc
  make-doc ed diffutils-doc
The following NEW packages will be installed:
  build-essential bzip2 cpp cpp-8 dpkg-dev fakeroot g++ g++-8 gcc gcc-8
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libasan5 libcc1-0 libfakeroot libgcc-8-dev libisl19 libmpc3 libmpfr6
  libstdc++-8-dev libubsan1 make patch
0 upgraded, 24 newly installed, 0 to remove and 7 not upgraded.
Need to get 27.8 MB of archives.
After this operation, 93.0 MB of additional disk space will be used.
Get:2 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf libisl19 armhf 0.20-2 [439 kB]
Get:7 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf libcc1-0 armhf 8.3.0-6+rpi1 [37.9 kB]
Get:9 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf libubsan1 armhf 8.3.0-6+rpi1 [103 kB]
Get:12 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf gcc armhf 4:8.3.0-1+rpi2 [5200 B]
Get:13 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf libstdc++-8-dev armhf 8.3.0-6+rpi1 [1545 kB]
Get:15 http://raspbian.raspberrypi.org/raspbian buster/main armhf g++ armhf 4:8.                                                                             3.0-1+rpi2 [1632 B]
Get:19 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf build-essential armhf 12.6 [7568 B]
Get:21 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf fakeroot armhf 1.23-1 [85.2 kB]
Get:24 http://mirror1.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf libalgorithm-merge-perl all 0.08-3 [12.7 kB]
Get:1 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf bzip2 armhf 1.0.6-9.2~deb10u1 [46.2 kB]
Get:3 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf libmpfr6 armhf 4.0.2-1 [723 kB]
Get:4 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf libmpc3 armhf 1.1.0-1 [32.1 kB]
Get:5 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf cpp-8 armhf 8.3.0-6+rpi1 [6787 kB]
Get:6 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf cpp armhf 4:8.3.0-1+rpi2 [19.6 kB]
Get:8 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bus                                                                             ter/main armhf libasan5 armhf 8.3.0-6+rpi1 [317 kB]
Get:10 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf libgcc-8-dev armhf 8.3.0-6+rpi1 [595 kB]
Get:11 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf gcc-8 armhf 8.3.0-6+rpi1 [7223 kB]
Get:14 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf g++-8 armhf 8.3.0-6+rpi1 [7464 kB]
Get:16 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf make armhf 4.2.1-1.2 [321 kB]
Get:17 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf patch armhf 2.7.6-3+deb10u1 [115 kB]
Get:18 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf dpkg-dev all 1.19.7 [1773 kB]
Get:20 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf libfakeroot armhf 1.23-1 [43.3 kB]
Get:22 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf libalgorithm-diff-perl all 1.19.03-2 [47.9 kB]
Get:23 http://mirror0.it.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian bu                                                                             ster/main armhf libalgorithm-diff-xs-perl armhf 0.04-5+b1 [11.4 kB]
Fetched 27.8 MB in 12s (2372 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package bzip2.
(Reading database ... 34194 files and directories currently installed.)
Preparing to unpack .../00-bzip2_1.0.6-9.2~deb10u1_armhf.deb ...
Unpacking bzip2 (1.0.6-9.2~deb10u1) ...
Selecting previously unselected package libisl19:armhf.
Preparing to unpack .../01-libisl19_0.20-2_armhf.deb ...
Unpacking libisl19:armhf (0.20-2) ...
Selecting previously unselected package libmpfr6:armhf.
Preparing to unpack .../02-libmpfr6_4.0.2-1_armhf.deb ...
Unpacking libmpfr6:armhf (4.0.2-1) ...
Selecting previously unselected package libmpc3:armhf.
Preparing to unpack .../03-libmpc3_1.1.0-1_armhf.deb ...
Unpacking libmpc3:armhf (1.1.0-1) ...
Selecting previously unselected package cpp-8.
Preparing to unpack .../04-cpp-8_8.3.0-6+rpi1_armhf.deb ...
Unpacking cpp-8 (8.3.0-6+rpi1) ...
Selecting previously unselected package cpp.
Preparing to unpack .../05-cpp_4%3a8.3.0-1+rpi2_armhf.deb ...
Unpacking cpp (4:8.3.0-1+rpi2) ...
Selecting previously unselected package libcc1-0:armhf.
Preparing to unpack .../06-libcc1-0_8.3.0-6+rpi1_armhf.deb ...
Unpacking libcc1-0:armhf (8.3.0-6+rpi1) ...
Selecting previously unselected package libasan5:armhf.
Preparing to unpack .../07-libasan5_8.3.0-6+rpi1_armhf.deb ...
Unpacking libasan5:armhf (8.3.0-6+rpi1) ...
Selecting previously unselected package libubsan1:armhf.
Preparing to unpack .../08-libubsan1_8.3.0-6+rpi1_armhf.deb ...
Unpacking libubsan1:armhf (8.3.0-6+rpi1) ...
Selecting previously unselected package libgcc-8-dev:armhf.
Preparing to unpack .../09-libgcc-8-dev_8.3.0-6+rpi1_armhf.deb ...
Unpacking libgcc-8-dev:armhf (8.3.0-6+rpi1) ...
Selecting previously unselected package gcc-8.
Preparing to unpack .../10-gcc-8_8.3.0-6+rpi1_armhf.deb ...
Unpacking gcc-8 (8.3.0-6+rpi1) ...
Selecting previously unselected package gcc.
Preparing to unpack .../11-gcc_4%3a8.3.0-1+rpi2_armhf.deb ...
Unpacking gcc (4:8.3.0-1+rpi2) ...
Selecting previously unselected package libstdc++-8-dev:armhf.
Preparing to unpack .../12-libstdc++-8-dev_8.3.0-6+rpi1_armhf.deb ...
Unpacking libstdc++-8-dev:armhf (8.3.0-6+rpi1) ...
Selecting previously unselected package g++-8.
Preparing to unpack .../13-g++-8_8.3.0-6+rpi1_armhf.deb ...
Unpacking g++-8 (8.3.0-6+rpi1) ...
Selecting previously unselected package g++.
Preparing to unpack .../14-g++_4%3a8.3.0-1+rpi2_armhf.deb ...
Unpacking g++ (4:8.3.0-1+rpi2) ...
Selecting previously unselected package make.
Preparing to unpack .../15-make_4.2.1-1.2_armhf.deb ...
Unpacking make (4.2.1-1.2) ...
Selecting previously unselected package patch.
Preparing to unpack .../16-patch_2.7.6-3+deb10u1_armhf.deb ...
Unpacking patch (2.7.6-3+deb10u1) ...
Selecting previously unselected package dpkg-dev.
Preparing to unpack .../17-dpkg-dev_1.19.7_all.deb ...
Unpacking dpkg-dev (1.19.7) ...
Selecting previously unselected package build-essential.
Preparing to unpack .../18-build-essential_12.6_armhf.deb ...
Unpacking build-essential (12.6) ...
Selecting previously unselected package libfakeroot:armhf.
Preparing to unpack .../19-libfakeroot_1.23-1_armhf.deb ...
Unpacking libfakeroot:armhf (1.23-1) ...
Selecting previously unselected package fakeroot.
Preparing to unpack .../20-fakeroot_1.23-1_armhf.deb ...
Unpacking fakeroot (1.23-1) ...
Selecting previously unselected package libalgorithm-diff-perl.
Preparing to unpack .../21-libalgorithm-diff-perl_1.19.03-2_all.deb ...
Unpacking libalgorithm-diff-perl (1.19.03-2) ...
Selecting previously unselected package libalgorithm-diff-xs-perl.
Preparing to unpack .../22-libalgorithm-diff-xs-perl_0.04-5+b1_armhf.deb ...
Unpacking libalgorithm-diff-xs-perl (0.04-5+b1) ...
Selecting previously unselected package libalgorithm-merge-perl.
Preparing to unpack .../23-libalgorithm-merge-perl_0.08-3_all.deb ...
Unpacking libalgorithm-merge-perl (0.08-3) ...
Setting up libalgorithm-diff-perl (1.19.03-2) ...
Setting up bzip2 (1.0.6-9.2~deb10u1) ...
Setting up libfakeroot:armhf (1.23-1) ...
Setting up fakeroot (1.23-1) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (                                                                             fakeroot) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/es/man1/fakeroot.1                                                                             .gz because associated file /usr/share/man/es/man1/fakeroot-sysv.1.gz (of link g                                                                             roup fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/es/man1/faked.1.gz                                                                              because associated file /usr/share/man/es/man1/faked-sysv.1.gz (of link group f                                                                             akeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/fr/man1/fakeroot.1                                                                             .gz because associated file /usr/share/man/fr/man1/fakeroot-sysv.1.gz (of link g                                                                             roup fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/fr/man1/faked.1.gz                                                                              because associated file /usr/share/man/fr/man1/faked-sysv.1.gz (of link group f                                                                             akeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/sv/man1/fakeroot.1                                                                             .gz because associated file /usr/share/man/sv/man1/fakeroot-sysv.1.gz (of link g                                                                             roup fakeroot) doesn't exist
update-alternatives: warning: skip creation of /usr/share/man/sv/man1/faked.1.gz                                                                              because associated file /usr/share/man/sv/man1/faked-sysv.1.gz (of link group f                                                                             akeroot) doesn't exist
Setting up libasan5:armhf (8.3.0-6+rpi1) ...
Setting up make (4.2.1-1.2) ...
Setting up libmpfr6:armhf (4.0.2-1) ...
Setting up libmpc3:armhf (1.1.0-1) ...
Setting up patch (2.7.6-3+deb10u1) ...
Setting up libubsan1:armhf (8.3.0-6+rpi1) ...
Setting up libisl19:armhf (0.20-2) ...
Setting up cpp-8 (8.3.0-6+rpi1) ...
Setting up libalgorithm-diff-xs-perl (0.04-5+b1) ...
Setting up libcc1-0:armhf (8.3.0-6+rpi1) ...
Setting up libalgorithm-merge-perl (0.08-3) ...
Setting up dpkg-dev (1.19.7) ...
Setting up libgcc-8-dev:armhf (8.3.0-6+rpi1) ...
Setting up cpp (4:8.3.0-1+rpi2) ...
Setting up libstdc++-8-dev:armhf (8.3.0-6+rpi1) ...
Setting up gcc-8 (8.3.0-6+rpi1) ...
Setting up gcc (4:8.3.0-1+rpi2) ...
Setting up g++-8 (8.3.0-6+rpi1) ...
Setting up g++ (4:8.3.0-1+rpi2) ...
update-alternatives: using /usr/bin/g++ to provide /usr/bin/c++ (c++) in auto mo                                                                             de
Setting up build-essential (12.6) ...
Processing triggers for libc-bin (2.28-10+rpt2+rpi1) ...
volumio@volumio:~$ cd ~
volumio@volumio:~$ wget http://plugins.volumio.org/plugins/volumio/armhf/system_                                                                             controller/gpio-buttons/gpio-buttons.zip
--2021-12-04 21:44:35--  http://plugins.volumio.org/plugins/volumio/armhf/system                                                                             _controller/gpio-buttons/gpio-buttons.zip
Resolving plugins.volumio.org (plugins.volumio.org)... 192.64.119.194
Connecting to plugins.volumio.org (plugins.volumio.org)|192.64.119.194|:80... co                                                                             nnected.
HTTP request sent, awaiting response... 302 Found
Location: http://plugins.volumio.workers.dev/plugins/volumio/armhf/system_contro                                                                             ller/gpio-buttons/gpio-buttons.zip [following]
--2021-12-04 21:44:40--  http://plugins.volumio.workers.dev/plugins/volumio/armh                                                                             f/system_controller/gpio-buttons/gpio-buttons.zip
Resolving plugins.volumio.workers.dev (plugins.volumio.workers.dev)... 172.67.15                                                                             3.54, 104.21.34.20, 2606:4700:3030::ac43:9936, ...
Connecting to plugins.volumio.workers.dev (plugins.volumio.workers.dev)|172.67.1                                                                             53.54|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1096326 (1.0M) [application/zip]
Saving to: 'gpio-buttons.zip'

gpio-buttons.zip    100%[===================>]   1.04M  6.43MB/s    in 0.2s

2021-12-04 21:44:41 (6.43 MB/s) - 'gpio-buttons.zip' saved [1096326/1096326]

volumio@volumio:~$ mkdir ./gpio-buttons
volumio@volumio:~$ miniunzip gpio-buttons.zip -d ./gpio-buttons
MiniUnz 1.01b, demo of zLib + Unz package written by Gilles Vollant
more info at http://www.winimage.com/zLibDll/unzip.html

gpio-buttons.zip opened
 extracting:.....snip
volumio@volumio:~$ cd gpio-buttons
volumio@volumio:~/gpio-buttons$ volumio plugin install

This command will install the plugin on your device

Compressing the plugin
Plugin succesfully compressed
Progress: 10
Status :Downloading plugin
nloading plugin at http://127.0.0.1:3000/plugin-serve/gpio-buttons.zip
Progress: 30
Status :Creating install location
Creating install location
Progress: 40
Status :Unpacking plugin
Unpacking plugin
Progress: 45
Status :Checking that the plugin is suitable for this version of Volumio The plu                                                                             gin has no node version dependency information. The plugin has no Volumio versio                                                                             n dependency information. The plugin may not work on this version of Volumio
Checking that the plugin is suitable for this version of Volumio The plugin has                                                                              no node version dependency information. The plugin has no Volumio version depend                                                                             ency information. The plugin may not work on this version of Volumio
Progress: 50
Status :Checking for duplicate plugin
Checking for duplicate plugin
Progress: 60
Status :Copying plugin to location
Copying plugin to location
Progress: 70
Status :Installing necessary utilities
Installing necessary utilities
Progress: 70
Status :Installing necessary utilities
Initializing config
Progress: 90
Status :Finalizing installation
Finalizing installation
Progress: 100
Status :GPIO Buttons Successfully Installed, Do you want to enable the plugin no                                                                             w?
Finalizing installation
Done! Plugin Successfully Installed
volumio@volumio:~/gpio-buttons$ ^C
volumio@volumio:~/gpio-buttons$ cd /data/plugins/system_controller/gpio-buttons/
volumio@volumio:/data/plugins/system_controller/gpio-buttons$ npm install --save                                                                              onoff@6.0.0

> epoll@4.0.1 install /data/plugins/system_controller/gpio-buttons/node_modules/epoll
> node-gyp rebuild

make: Entering directory '/data/plugins/system_controller/gpio-buttons/node_modules/epoll/build'
  CXX(target) Release/obj.target/epoll/src/epoll.o
  SOLINK_MODULE(target) Release/obj.target/epoll.node
  COPY Release/epoll.node
make: Leaving directory '/data/plugins/system_controller/gpio-buttons/node_modules/epoll/build'
npm WARN gpio-buttons@0.8.1 No repository field.

+ onoff@6.0.0
added 2 packages from 4 contributors, updated 4 packages and audited 61 packages in 12.827s
found 7 vulnerabilities (3 low, 3 high, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details
volumio@volumio:/data/plugins/system_controller/gpio-buttons$

1 Like

please re-flash the latest image on a SD-card and to the procedure again, you already had some attempt in your system

OK . everything made new. and now it worked. had a few errors during installation, but it works.
Thanks

Hi M1ck,
Could you summarize or show only commands for ssh (GPIO buttons install)?
Thanks

Hi Alain

I posted how I did in this thread here post 2 although, further down Ashthespy posted a more streamlined way of doing this.