Install any plugins fails when creating folder!

Hi all -

I’m an RPi and Volumio rookie. I’m trying to rework an old family console radio to be a touchscreen Volumio system. First, I’ve got to say that Volumio is an awesome product and kudos to the dev team!

I’ve got the card flashed and the system up and running. I, however, need to install the touchscreen and Spotify plugins. I’ve tried both and get the exact same thing. The .zip downloads no problem, but after it says “Creating folder on disk” I get an error. It’s almost as if it doesn’t have write permissions or something.

Downloading plugin at http://volumio.github.io/volumio-plugins/plugins/volumio/armhf/miscellanea/touch_display/touchdisplay.zip END DOWNLOAD: http://volumio.github.io/volumio-plugins/plugins/volumio/armhf/miscellanea/touch_display/touchdisplay.zip Creating folder on disk The folowing error occurred when installing the plugin: Error

I’ve reflashed the most recent Volumio, made no changes before trying to add plugins, but still same error occurs.

Any help from anyone would be endlessly helpful! Was hoping to have this done for Christmas and surprise the wife.

Take care all!
Marc

Did you change password before installing plugin? Plugin installation isnt smart enough to ask your new password. Just change it back to volumio

See https://community.volumio.org/t/touch-display-plugin-error/4620/2
Your message is a bit earlier. There might be an existing folder /tmp/downloaded_plugin mentioned in line 439 in app/pluginmanager.js ? Try to change access rights of or remove the folder… Good luck!