Indexing large library fails

My Hardware:
-Raspberry Pi 3
-Raspberry Pi 4 (4GB)
-Synology NAS 416j (NFS Share)
-USB 3.0 HDD
(NAS and HDD contain the same files)

The Problem (USB):
The Indexing started fast and showed the progress of discovered files under the “sources/quellen”-menu until the refresh stopped at a specific number.

How i solved the problem:
I started a search in Windows (on the drive) with the keyword *. Then i sorted the results by file-Type and deleted everything that was not, a picture, not a flac and not a cue file.
After that i imported every flac flie to “Foobar2000” and sorted by bitrate. Than i deleted every file which has no bitrate,

I can relate to this issue.
I’ve got a 6TB HDD which is accessable (putty -> cd /media/…)
In Volumio i can’t acces the containing media.
If i start indexing in the sources menu, nothing happens.
In Media Library is the drive also not shown.

I’m running a PI4 / 4GB wit Volumio 2.699 (and yes, i’ll update and try aggain.

@Volumio Admins: Please fix this.

Update :
To see if this is an MPD-realated issue i’ve made a test.
I’ve set up my Raspberry Pi 4 with “Moode Audio” and connected my USB HDD.
After a few hours the whole HDD was indexed without anny issues.
So I guess it’s an volumio-specific issue.

So, Yesterday Evening I Updatet my Volumio to 2.714 and started indexing from USB Hdd aggain.

What should I say?
With 2.714 it started indexing…

…But stopped exactly at 56266 Songs.

This is really awefull!

Please Investigate and fix this!

My Hardware:
-volumio-2.714 fresh installed
-Raspberry Pi 3B+ (2x)
-Synology NAS 414 16TB (NFS Share)

Unfortunately i have the same problems as Maschine2501 described.
after four times (hard) restart and push the button ‘update’ again and within three days all of my music was indexed on both raspberrys.

6,92 TB Flac music
13039 Albums
91710 Tracks
6752 hours playtime

I think there is a really problem with large collections

Thank you for your feedback!
I didn’t mention that i hard resetted so many times that i couldn’t remember how often.
I really have tried every god damn way…

Look at my first post and try the solution :wink: