I'm struggling to mount a shared folder on a Mac


I have all my music on a shared folder on my mac.

5k iMac HD⁩ ▸ ⁨Users⁩ ▸ ⁨dominicrutterford⁩ ▸ ⁨Documents⁩ ▸ ⁨Work in progress⁩ ▸ ⁨Dropbox⁩ ▸ ⁨Dominic Music

or as Terminal shows it: /Users/dominicrutterford/Documents/Work\ in\ progress/Dropbox/Dominic\ music

The sharing control panel tells me my mac is: smb://dominicds5kimac.home

How do I enter these into the My Music -> Network Drives to make this work.

Thanks in advance.

If the NAS folder is detectable, Volumio will automatically find it when you go to Settings > My Music > Network Drives > Add Network Drive.

It’s not strictly a NAS.

It’s a shared folder on a mac.

It does see it when I Add Network Drive but it wont let me mount it.

I’ve had this problem for years with all Macs and I fixed it once through luck rather than judgement - but the SD card corrupted on an update and I can’t remember how I did it.

It’s taken two years of fiddling and I still don’t understand why this is happening. Others have had the same issue and there is no definitive answer anywhere on this forum that I can find (and I think some old posts have been removed).

It just needs the path etc entering correctly…

So it’s a NAS: Network Attached Storage. In other words, storage accessible via the local network. It’s not a dedicated NAS though, since it’s also used for other purposes.

Verify that you chose the right path. That is, when you select the storage from the list in Volumio, set the path .
Also, for testing, make sure that the Mac is set to allow guest acces to this share.

You might have to set additional options for the mount. Not sure what OS X uses. Google how to mount a share from OS X on Linux and you’ll surely find the right parameters. And then write them down :wink:

Of course I’ve tried all of the things you listed. Hence why I’m on here to see if anyone has cracked it.

It would have helped to specify that, so that we can skip the obvious solutions :wink:
So, which steps and options did you already try?

Secondly, the auto-mount via the webUI does not give a whole lot of feedback I think. Can you try to mount the share via the command line (via SSH) and see which errors are returned?

Just a quick Google search already results in a few options to try from OS X to Raspbian:
superuser.com/questions/1239142 … spberry-pi
reddit.com/r/raspberry_pi/c … e_on_a_pi/

I’ve sorted it.

It just needs IP address not smb address the Mac gives you. This means you need a fixed IP not assigned by DCHP.

Then just the name of the share folder not the folder path.

It’s so annoying that it’s hiding in plain sight! Any Mac users with same problem message me for further info if needed. A server error stops me uploading screenshots on this forum at moment.


1 Like

Hi there! I’m having issues connecting my Volumio to the hard drive on my mac as well. Any help would be appreciated.

Glad you’ve sorted it domchocolate, differences between share names and folder paths are always a problem on different devices … it depends exactly how it is broadcast over the network ie. what does Volumio “see” as a potential share.

Yes, it does need a fixed IP address, again this comes down to the same as above. Names such as MyLaptop.local are great, but somewhere that needs translating into an actual IP address.

BTW. I’ve selected your reply as the “solution” to the OP, if you’e not happy with that you may edit it yourself back.

@selfishagenda please open a new post fully describing your system, Volumio version and problem please. For the sake of other users, your post will just be ‘lost’ here otherwise.

@chsims1 Sure. Made a new detailed post here: