IFTTT Triggers stopped working

Hope i am in the correct spot! First post, so be gentle please. Had a bunch of IFTT triggers setup to control my Volumio via Alexa but it’s stopped working in the last 2 days

What’s weird is, if i copy the IFTTT trigger URL, e.g.,
http://<url/ip-address of my router>:3000/api/v1/commands/?cmd=playplaylist&name=LyricFM

And paste that into my broswer, it carries out the function as expected, just not from IFTTT/Alexa

Anybody have any thoughts as to why this might be happening? Running version 2.852 on a Raspberry PI

Are you sure IFTTT is able to access your pi’s IP from outside your network?
Probably a first test would be to try a simpler API command such as pause or something.
i.e is it only endpoint that is giving you trouble or all endpoints…

To be honest with you, I only have IFTTT to control the Volumio, so don’t have any other triggers setup. None of the triggers work, even simple ones, e.g.

http://<url/ip of router>:3000/api/v1/commands/?cmd=stop

I also have port forwarding setup to allow the command to come thru so don’t think that’s an issue.

Well, if it’s working from within your network, but not from outside, wouldn’t that suggest your port forwarding is not working?

There has been a bug discovered in 2.852 which prevents some REST API calls to fail if no user agent is specified.
I think this is the issue.
It will be solved in a new release this weekend

I believe TS is having issues with the IFTTT implementation of calling a webhook, rather than port forwarding (or I’m missing something). TS claims that calling the URL from a browser yields results, but have IFTTT calling it doesn’t.

Just to be one the safe side, if you use an IP rather than a name (this rules out DNS issues), is it still not working?

Also, is there a difference in calling the outside router IP vs the inside one? Should make a difference for the forwarding rule, but let’s assume both are in place. This should test if there’s other functionality in the router blocking WAN to LAN traffic.

I have no IFTTT experience, so my questions/assumptions are solely based on network knowledge.

Calling is very different from calling (NATed to from a firewall perspective.

I was too late with my reply, but nonetheless it might help people understand networking :rofl:

Boom! :boom: Updated to 2.853 just now, IFTTT triggers working again. Thank you very much indeed for the quick turnaround. Nice work