i2s Playback Stuck - Raspberry Pi - HiFiBerry

Hi everyone

I am in the middle of trying to to set up Volumio as a hotspot so that I can use it in a portable stereo. It took me a while but I got the WiFi to work as an access point, and now I am on my next problem, but this one I cannot crack.

I have just put the HiFiBerry on the Raspberry Pi. I read up on how to get it working, and it seemed rather simple, change the setting to i2sOn, reboot, and profit. The problem is, it seems to have a strange affect on how the Rpi works. When ever I have i2s set to On, I can get into volumio.local/ I can see all the songs, add them and press play, but it seems to just sit there, the play button has changed to a pause, but the timer wont move and no sound through any of the ports. Same on multiple devices. turn i2s back to off, and the sound works fine through the 3.5mm port again.

What I have tried, well… Obviously reboot it 100 times… heh, I also tried rpi-update, I saw it mentioned while trying to search for the issue that some version of Volumio had an issue with i2s, and that was the fix. Unfortunately this has not resolved my issue.

I will just point out another 1 other strange occurrence, on the iPhone, the airplay disappears as soon as you try and steam anything to volumio…

I don’t really have a screen to connect to Volumio, so it makes it a little hard to see if there are any errors, I am posting here in the hopes that this is a known issue and that there is a fix for it.

Regards
Kirt

https://community.volumio.org/t/feedback-on-the-hifi-berry-dac/575/1

Sent from my Nexus 4 using Tapatalk

Thank you, I did try searching but it wouldn’t let me search for i2s or anything.

I took the device to work and tried what was mentioned in the post, and for the most part it looks like it has started counting, unfortunately I have no way to test the audio output at work. But so far so good. Ill test it at home this arvo and let you know.

Thank you.

Just tested and this has solved my issues, thank you. I ended up getting another error and had to restart the Mdp haha, but all working fine.

Thank You