I am NOT able to make my Spotify plugin to work, no mater what I do?

Hi All,

I have just started to work with the wonderful Volumio.
I installed it on my Ubuntu Linux machine 18.04 under a docker using docker compose:

version: "3.8"
    image: jbonjean/volumio:latest
    container_name: volumio
    hostname: volumio
      - PUID=0
      - PGID=0
      - HOST=https://volumio.myspecialdomain.duckdns.org
      - /mnt/musics:/var/lib/mpd/music/:ro
      - ./data:/data
      - 30033:3000
    restart: unless-stopped
      - /dev/snd:/dev/snd
      - traefik_proxy
    external: true

I have tried several configurations of compose using 1000:1000 as well before switching to root as seen above. The one I have now works, I have a configurations for traefik to have the volumio behind https.
Docker installation is latest as the compose show.jbonjean/volumio:latest
the docker works great and I am able to hear songs from my volumio server. Everything looks OK and I am not sure what is wrong since…

To start - I already have Spotify Premium Account

I installed the latest Spotify plugin Version 2.0.2
And after enabling the plugin I am ONLY greeted with username and password. Nothing more.
Everywhere UI look I see refresh_token as well.

But I am NOT sure why I am NOT able to make Spotify ran?
After providing username and password - I see the green indicator showing that it sign in - and I was hoping to see Spotify on my Volumio - But NO!

I can’t see Spotify at all in my volumio server.
I would be happy if some one can assist me.
I want to be able to connect Spotify to my Volumio.

I also went to Spotify developer Dashboard and created an app to get me with user id and secret and redirect URL. that I probably use to get refresh token in the future.

I also edited files in /plugins/music_service/spop folder the config.json
as followed (fake entries):

  "enabled": {
    "type": "boolean",
    "value": false
  "username": {
      "type": "string",
      "value": "dtdtrgervytfghybhhjjnujnukju-fake"
  "password": {
    "type": "string",
    "value": "fakepass"
  "bitrate": {
    "type": "boolean",
    "value": true
  "refresh_token": {
    "type": "string",
    "value": "AAAAAAAAAAAAAAAAAA_L5Xbl6sZ7OYv355-GeJmIumty6PJjjhijcgheFFGTTUUGBBHY_FAKE_KXxTJ3gexawOX0zPBGmKyphgIjeV_pQQsej_OW1mRZ-ibOvE-ECT8RXHTyQ"

But in general I have setup up there what I thought is the CORRECT place to do so.
Also edited the spop.conf.tmpl file:

spotify_username = dtdtrgervytfghybhhjjnujnukju-fake
spotify_password = fakepass
high_bitrate = true
refresh_token = AAAAAAAAAAAAAAAAAA_L5Xbl6sZ7OYv355-GeJmIumty6PJjjhijcgheFFGTTUUGBBHY_FAKE_KXxTJ3gexawOX0zPBGmKyphgIjeV_pQQsej_OW1mRZ-ibOvE-ECT8RXHTyQ
audio_output = sox
pretty_json = true
search_results = 50
cache_path =/run/shm

output_type = alsa
output_name = ${outdev}

Hoping it will make Spotify come to life! But NO.
I don’t know what to do? I am sure doing something wrong and I would be happy to make volumio playing my Spotify files.

It would be great having Spotify also running on my Volumio server of which I was hoping to put another one outside as well.

Please assist with Spotify Plugin on my Volumio docker installation.
Thank you!