How to start the DLNA Server for Volumio 1.5 on the Pi

So you’ve got a new Blu-Ray player or Smart TV, and it has DLNA. Wouldn’t it be nice if you could listen to all of that music on the USB flash drive or hard drive that is attached to your Volumio system. You can, but it’s going to require a little bit of manual editing.

The reason that it was disabled is that there are performance issues with the Raspberry Pi when streaming from the DLNA server and playing music on the PI at the same time. If you can deal with this, here is how you re-enable it.

First, on the volumio/ web page, click on MENU, and then System, and make sure that DLNA Library Server is ON. Reboot if you just turned it on.
Then point your web browser to volumio:8200/ . You should see that the DLNA server is running, but it isn’t serving up any files. So how do we fix this? This next part has to be done manually.

Start up your SSH program (Putty) on your PC, or hook up a keyboard and monitor to your Pi, and log into Volumio (user: root pw: volumio)
We are now going to edit a file.
nano /etc/minidlna.conf
Remove the leading # from this line
then save it by doing a bO[/b] and exit by doing a bX[/b]

You can restart the DLNA server with the following command
service minidlna restart
or you can reboot.

If you refresh volumio:8200/ , you should notice that the DLNA server can now see the your files. Your DLNA server is ready to go.

many thanks for posting this. I’ve tried this several times and at the beginning it works (I had to use “sudo nano” to edit the file as “nano” didn’t allow me to save the edited file).
I can see the library building up on the MiniDLNA status page (and I can see the files on other devices which pick up this DLNA server). However once the library is finished (about 15,000 audio files) the library disappears and the status page shows:

MiniDLNA status
Audio files: -1
Video files: -1
Image files: -1

And now the DLNA server is still visible from other devices but it is empty. I can run Volumio OK from the “Browse” / USB section, but the Volumio ibrary does not show from the Library tab. I am running 1.55 on a “B” Pi .

Any ideas what might be happening?

i have the same problem (miniDLNA updates the files and goes back to “-1”
i wonder if there isnt a limit of files to be handled by “minidlna”
i wonder if RPI + Volumio is suited for large collection (> 20 k files).
how could i have my Rpi have volumio AND a DLNA server running, both ?

some more informations

MiniDLNA status
Audio files: 16192
Video files: 10
Image files: 1421

5 sec later
MiniDLNA status

Audio files: -1
Video files: -1
Image files: -1

RPI model B
sd card 8 Go
USB hdd samsung S2 500 Go
so limit around 16 000 files ? for me at least (2 times, same number, ish)


It’s me again

just to share information

1- i did a full upate and upgrade
sudo apt-get update
sudo apt-get upgrade

2- i updated minidlna
sudo apt-get install minidlna

3- then i rebooted and launched the minidlna service
sudo service minidlna restart

4- the dlna process did happen “normally”, and went through all my files
by the way, the web interface includes now the clients that have been connected

MiniDLNA status

Media library
Audio files 38843
Video files 16
Image files 2979

Connected clients
ID Type IP Address HW Address
0 Generic UPnP 1.0 E8:BE:81:13:4F:84
1 Generic DLNA 1.5 00:60:B3:B6:EA:C1
2 Generic DLNA 1.5 C8:60:00:A4:83:09
3 Generic UPnP 1.0 5C:2E:59:12:77:E2

BUT (because there is one but)
the minidlna process is consuming between 72% and 98% of the CPU (using “top” command)
any idea to lower that usage ??


Thanks for this response. I am having the same problem. I upgraded and re-installed minidlna. But I get the following message:

Which choice do I make? I tried ‘no,’ but this seems to have broken the library function in the GUI.