How to remove NAS mount?


Been a long time user of Volumio 1.x. So I recently installed Volumio 2.x version on RasPi 3. Added my music through NAS. My Music->Add new drive, etc.

It defaults to music and I just pointed to the root folder of my NAS drive, login information, etc. It worked fine. However, I would like to remove it and add a different NAS. I just cannot figure out how to remove the My Library. Could someone point me to documentation that shows how to add and remove libraries?

go in my music and just ckick on the bin on right of the screen
rmove nas.png

thanks. Unfortunately I do not see that delete button. Could you think of any reason why I am not seeing that line?

Hello there,

I’m having the same problem/wisch as canbonbon has: I made a small folder on my nas for testing the mounting process (it’s my first volumio machine and it’s running the latest V2.001). I managed to mount the test folder, but now I can’t remove it. I’ve attached a screenshot.


I tried to add another test folder: but that isn’t mounted at all.
( Neither a cfis nor a nfs share worked here; all settings are correct).

My music is stored on a Synology DS415play, cfis and nfs shares are enabled.

Does anyone have an idea what’s wrong?

Thank you very much in advance

Sometimes lists in the web UI take a little while to appear (asynchronous calls it seems), or fail to be populated at all (asynchronous call timeout?)

Some ideas:

  • Is the NAS mounted (you can access your music) but not visible on the page?
  • Does Volumio have full network access all of the time, or are there downtimes?
  • Have you tried reloading the page by entering its URL again (to clear the call of any POST messages) or checking the web browser’s error log (Ctrl+Shift+I)?
  • Trying another browser may be worthwhile.
  • What happens if you add yet another NAS? Does it become visible?
  • If everything fails you can always reinstall Volumio.