How to recover from ALSA USB device failure

I’ve been running Volumio on a Pi for about two weeks now. Works great for the most part. One little quirk I notice is that the USB occaisonally disconnects or reconnects (or something), and then ALSA device can’t reload. When this happens and I try to play a track, I get the following message:

ALSA lib pcm_hw.c:1401:(_snd_pcm_hw_open) Invalid value for card
Mar 25 17:57 : output: Failed to open “Output” [alsa]: Failed to open ALSA device “hw:0,0”: No such file or directory
Mar 25 17:57 : player_thread: problems opening audio device while playing “NAS/Shared Music/Paul McCartney/Back in the U.S/14. Lady Madonna.flac”

This brings me to two questions:

  1. Is there a way to recover from this without rebooting? I’ve tried restarting the alsa-utils service but that didn’t work.

  2. Is this a bug? Can it be corrected to make the Pi ->-usb->DAC work as plug and play?


Hi etsauer,

maybe sudo alsa reload or sudo alsa force-reload could help…


reloading alsa definitely has not helped with this issue. I’ve tried several times.

I’ve also tried restarting mpd, but nothing works. only thing that has done it is rebooting the Pi.

Here is a complete guide on how to recover files on linux: … eted-files